osession.request-trickle-id and ReadyAPI conundrum

4 posts, 0 answers
  1. Amy
    Amy avatar
    3 posts
    Member since:
    Jul 2015

    Posted 13 Jul 2015 Link to this post

    I am trying to apply osession.request-trickle-id values to SOAP and REST requests made via HTTPS from ReadyAPI. I'm making these requests within the company network.

    The setting appears to be ignored when I make ReadyAPI requests.

     I am definitely routing ReadyAPI traffic through Fiddler - I can see the requests in Fiddler. 

     If I simply browse the Web, however, it's easy to see that the request-trickle-id value IS being applied.

     I will say that the ReadyAPI requests I'm making are very tiny, but even huge osession.request-trickle-id values have no effect.

     Thoughts? thanks. 

  2. Amy
    Amy avatar
    3 posts
    Member since:
    Jul 2015

    Posted 13 Jul 2015 in reply to Amy Link to this post

    Correction - that's request-trickle-delay. Sorry about that. 
  3. Eric Lawrence
    Eric Lawrence avatar
    833 posts

    Posted 14 Jul 2015 Link to this post

    Hello, Amy--

    If you send me a SAZ file showing the problem, I'd be happy to have a look at it. Having said that, even knowing exactly how tiny your requests are would be useful. 

    One key point: Have you enabled HTTPS decryption? If not, Fiddler's trickling behavior will not apply to requests made through a HTTPS connection.

    Eric Lawrence
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  4. Amy
    Amy avatar
    3 posts
    Member since:
    Jul 2015

    Posted 15 Jul 2015 in reply to Eric Lawrence Link to this post

    Hi Eric,

     Enabling HTTPS decryption did the trick. (I also had to install the Fiddler cert where the ReadyAPI JRE could get to it.)

     Thank you.


Back to Top