ORM SDK Browser

4 posts, 0 answers
  1. Erik
    Erik avatar
    314 posts
    Member since:
    Feb 2008

    Posted 09 Jun 2011 Link to this post

    Hi,

    When I use the OA SDK browser, examples, and select "best practices in web dev... OpenAcces 1" and then click "Open in VS" I get a dialog for a connection. It can't make (attach) the database local because of security, but I already have a sql server that has that database. When i select that server, do test connection all is fine, but when I select the option "Select or Enter a Database name" the textbox under it stays disabled...

    Erik
  2. Serge
    Admin
    Serge avatar
    375 posts

    Posted 13 Jun 2011 Link to this post

    Hi Erik,

     In order for the SDK Browser application to see the available databases that you have installed you need to activate the SQLBrowser windows service. After you have done that you will see the combo box populated with your database. The combo box should be enabled for input though and we will be fixing this issue. 

    As to the database install issue with security that is already fixed and will be available trough our next SDK release. The problem is that the default folder the SDK copies the databases is user specific and while trying to attach it the active user is the SQL Server's Network Service account that does not have credentials for these files. If you were to change the cache output dir (trough the Sample Cache Settings button on your Samples tab) to something like C:\OpenAccessSDK for example this should not be a problem. 

    I hope this proves to be helpful and please do not hesitate to let us know if you face further trouble. 

    Regards,
    Serge
    the Telerik team
    Q1’11 SP1 of Telerik OpenAccess is available for download; also available is the Q2'11 Roadmap for Telerik OpenAccess ORM.
  3. DevCraft banner
  4. Erik
    Erik avatar
    314 posts
    Member since:
    Feb 2008

    Posted 13 Jun 2011 Link to this post

    Hi Serge,

    The SQL Browser was disabled; new windows install lately. enabling and starting it did not change the behaviour of the dialog. I select (type) the database server name (sql express 2008 on win 2003, it's not showing in the dropdown) in the combobox. when I press "test connection" I get a positive answer. but the combobox for selecting the database is still disabled. 

    The data not in the profile ( or just the database at the default sql server 2008 location) will fix the security problem I think.

    maybe I should wait on Q2 for the first part?

    Regards,

    Erik
  5. Serge
    Admin
    Serge avatar
    375 posts

    Posted 14 Jun 2011 Link to this post

    Hi Erik,

     If you have the SQL Browser service enabled and the correct database installed (on any of the instances) the database tool window that pops up from the SDK will have the combo box populated with it, if not please try restarting the SDK Browser. If you press test connection and you don't have a database specified you will only test if the server is available. 

    You can always opt out from the database tool window but continue with the upgrade and run process. I will suggest that you try "Open in Visual Studio" and opt out of the window. In the end you will only need to modify your connection strings in order to make it work. 

    And what you have suggested is exactly what we have implemented, however it will be released either prior to Q2 or with it. I will notify you in this thread when the new SDK is released. 

    Still I see no need to wait for the Q2.

    I hope this is helpful.

    Regards,
    Serge
    the Telerik team
    Q1’11 SP1 of Telerik OpenAccess is available for download; also available is the Q2'11 Roadmap for Telerik OpenAccess ORM.
Back to Top