OpenAccess SDK Browser: Access to the path 'C:\Program Files (x86)\Telerik\OpenAccess ORM\ProductSdk\Temp' is denied.

2 posts, 0 answers
  1. Mark Jerde
    Mark Jerde avatar
    5 posts
    Member since:
    Oct 2009

    Posted 03 Jan 2011 Link to this post

    I just downloaded and installed the SDK but the browser won't run.  Where are the "Rich Set of Samples"?

    Error Dialog Box
    ---------------------------
    Error writing file
    ---------------------------
    Access to the path 'C:\Program Files (x86)\Telerik\OpenAccess ORM\ProductSdk\Temp' is denied.
    ---------------------------
    OK   
    ---------------------------

    Error Details Dialog Box
    ---------------------------

    ---------------------------
    The composition produced a single composition error. The root cause is provided below. Review the CompositionException.Errors property for more detailed information.



    1) Access to the path 'C:\Program Files (x86)\Telerik\OpenAccess ORM\ProductSdk\Temp' is denied.



    Resulting in: An exception occurred while calling the 'OnImportsSatisfied' method on type 'Telerik.Sdk.Browser.ViewModels.SamplesViewModel'.



    Resulting in: Cannot activate part 'Telerik.Sdk.Browser.ViewModels.SamplesViewModel'.

    Element: Telerik.Sdk.Browser.ViewModels.SamplesViewModel -->  Telerik.Sdk.Browser.ViewModels.SamplesViewModel -->  AssemblyCatalog (Assembly="Telerik.Sdk.Browser, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null")



    Resulting in: Cannot get export 'Telerik.Sdk.Browser.ViewModels.SamplesViewModel (ContractName="Telerik.Sdk.Browser.ViewModels.SamplesViewModel")' from part 'Telerik.Sdk.Browser.ViewModels.SamplesViewModel'.

    Element: Telerik.Sdk.Browser.ViewModels.SamplesViewModel (ContractName="Telerik.Sdk.Browser.ViewModels.SamplesViewModel") -->  Telerik.Sdk.Browser.ViewModels.SamplesViewModel -->  AssemblyCatalog (Assembly="Telerik.Sdk.Browser, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null")



    Resulting in: Cannot set import 'Telerik.Sdk.Browser.ViewModels.MainViewModel.SamplesViewModel (ContractName="Telerik.Sdk.Browser.ViewModels.SamplesViewModel")' on part 'Telerik.Sdk.Browser.ViewModels.MainViewModel'.

    Element: Telerik.Sdk.Browser.ViewModels.MainViewModel.SamplesViewModel (ContractName="Telerik.Sdk.Browser.ViewModels.SamplesViewModel") -->  Telerik.Sdk.Browser.ViewModels.MainViewModel -->  AssemblyCatalog (Assembly="Telerik.Sdk.Browser, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null")



    Resulting in: Cannot get export 'Telerik.Sdk.Browser.ViewModels.MainViewModel (ContractName="Telerik.Sdk.Browser.ViewModels.MainViewModel")' from part 'Telerik.Sdk.Browser.ViewModels.MainViewModel'.

    Element: Telerik.Sdk.Browser.ViewModels.MainViewModel (ContractName="Telerik.Sdk.Browser.ViewModels.MainViewModel") -->  Telerik.Sdk.Browser.ViewModels.MainViewModel -->  AssemblyCatalog (Assembly="Telerik.Sdk.Browser, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null")


    ---------------------------
    OK   
    ---------------------------
  2. Serge
    Admin
    Serge avatar
    375 posts

    Posted 04 Jan 2011 Link to this post

    Hello Mark Jerde,

     In order for the Telerik OpenAccess SDK to operate it has to have administrator rights. Unfortunately at the moment the SDK is not UAC aware and does not ask for the right credentials on start-up. You can easily avoid this issue by running the SDK as an administrator. Rest assured that this issue has been addressed and in the next version of the SDK you will not face the same issue.

    I am sorry for the inconvenience caused. Please do not hesitate to contact us back if you face further trouble.

    Kind regards,
    Serge
    the Telerik team
    Accelerate your learning with industry's first Telerik OpenAccess ORM SDK. Download today.
  3. DevCraft banner
Back to Top