OpenAccess and Ria Services

6 posts, 0 answers
  1. Ralf
    Ralf avatar
    10 posts
    Member since:
    Apr 2010

    Posted 02 Jul 2010 Link to this post

    Hi Telerik Team,

    i'm just evaluating OpenAccess within RiaServices.
    Visual Studio 2010 .Net 4 latest Silverlight Tools
    OpenAccess Trial from Today

    My first project did not get compiled because Telerik.OpenAccess.40.Extensions
    references Microsoft.Data.Services 3.5

    I found a releated thread in this forum ... but i dont want to reinstall my system ;-)

    So what i can do ? Do i really have to install the ADO.NET data service ctp for .Net 3.5 ?


    please help

    ... or nhibernate is the winner ;-)

  2. Dimitar Kapitanov
    Admin
    Dimitar Kapitanov avatar
    632 posts

    Posted 06 Jul 2010 Link to this post

    Hi Ralf Bellmann,
    Instead of manually adding a domain service and use the old context from Telerik.OpenAccess.40.Extensions (indeed targeted at the previous version of the services), just use the DataServices Wizard (that comes as a part of the OpenAccess installation) or through the Add New Item... dialog just select and add an OpneAccessDomainService to the project (you should use the latest Q1 SP2 release).

    Best wishes,
    Dimitar Kapitanov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft banner
  4. Ralf Bellmann
    Ralf Bellmann avatar
    2 posts
    Member since:
    May 2010

    Posted 06 Jul 2010 Link to this post

    Hi Dimitar,

    i'am working with a OA Version 2010.1.623.5.
    The reference to Telerik.OpenAccess.40.Extensions i removed and added a new telerik domain
    service (OpenAccessDomainService.tt) with the data wizard. strange that the dialog does not show avaiable entities.
    but ok now i have an empty datacontext.
    the error message after compilation is following:

    C:\Program Files\MSBuild\Microsoft\Silverlight\v4.0\Microsoft.Ria.Client.targets(303,5): error : Exception has been thrown by the target of an invocation.

    This is the CreateRiaClientFilesTask wich throws the error.

    Thanks
    Greetings from Cologne
    Ralf
  5. Dimitar Kapitanov
    Admin
    Dimitar Kapitanov avatar
    632 posts

    Posted 07 Jul 2010 Link to this post

    Hi Ralf Bellmann,
    Can you change to our latest Q1 SP2 release? The version is 2010.1 624 and it should be available for you for download. There the Ria implementation is verified to be correctly working. If that  is not fixing the issues, please send us the sample project that demonstrate the problem so that we can evaluate what is going on. To attach and send us the project you can open a support ticket (this is not possible in the forums).

    Kind regards,
    Dimitar Kapitanov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Ralf Bellmann
    Ralf Bellmann avatar
    2 posts
    Member since:
    May 2010

    Posted 09 Jul 2010 Link to this post

    Hi Dimitar,

    i just downloaded the free ORM-Express  with the promising version 2010_1_624.
    But inside i found a Folder with a Version 2010.1.623.5.


    Ralf
  7. Jan Blessenohl
    Admin
    Jan Blessenohl avatar
    707 posts

    Posted 12 Jul 2010 Link to this post

    Hi Ralf Bellmann,
    That is right, seems that the outer information is incorrect, that package is the right one.

    Kind regards,
    Jan Blessenohl
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top
DevCraft banner