Only the first filter action works on a loaded archive

5 posts, 0 answers
  1. Eitan
    Eitan avatar
    3 posts
    Member since:
    Sep 2015

    Posted 01 Sep 2015 Link to this post

    Hello,

    I use the currently latest version of Fiddler, 4.6.0.2, on Windows 7 64 bit.

    If I load a saved archive and run a filter action on it - it works fine.
    But any following filter actions, even disabling the filter and ru-running/applying the change - doesn't work and the list is "stuck" with the results of the first filter.
    I have to load again the archive a run each filter one at a time, one for each archive loading.

    Is this a known issue?

    Thanks,

    Eitan

     

     

  2. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 01 Sep 2015 Link to this post

    Hello, Eitan--

    Can you be specific about what exactly you are doing when you say "run a filter action"? Where do you click / type?

    Regards,
    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Eitan
    Eitan avatar
    3 posts
    Member since:
    Sep 2015

    Posted 01 Sep 2015 in reply to Eric Lawrence Link to this post

    Hello Eric,

     Here are the steps:

     1. Load an existing archive file
    2. Go to the "Filters" tab

    3. Check/Enable the ""use filters" check box

    4. enable a filter like "show only if URL contains" and type in a string

    5. click the sections' "Actions" button and click the command of "run filterset now" (this my meaning for "run a filter action")

    6. The list of sessions changes based on the filter

    (So far, all if fine)

    7. Disable the first (and only) filter and enable another filter and I apply/run it again (as mentioned on section 5 above)
    Nothing happens

    8. If, instead of section 7, I disable the "use filters" and "run" the "actions" button again - well, still, no change in the list of sessions. I expected the filter(s) to be removed and I will see the full original list of sessions.

    I see now that the same happens for a "live" capture of sessions.

    Also, it looks like running filters one after another can only omit sessions and there is no "way back" to the original list, before the filtering.

  4. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 01 Sep 2015 Link to this post

    In Fiddler, most filters delete traffic; the primary purpose of filters is to reduce the usage of memory by removing uninteresting request/response pairs. If you wish to highlight interesting traffic (instead of deleting uninteresting traffic) there are a variety of ways to do that.

    You didn't specify what filter you added in step #7, but if every session remaining in the Web Sessions list matched the filter criteria, then no change should be expected.

    Regards,
    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  5. Eitan
    Eitan avatar
    3 posts
    Member since:
    Sep 2015

    Posted 01 Sep 2015 in reply to Eric Lawrence Link to this post

    Wow, that's BAD...

    I didn't see this fact mentioned on the UI or in the help page at http://docs.telerik.com/fiddler/KnowledgeBase/Filters.

    This is very misleading as the default idea for filters is to hide non-matching records and show only matching records, with the ability to remove the filter and then go back to see the whole initial and complete list of records (if, of course, no actions like deletions were made on any record(s))

    1. Please mention this in bold and red prominent warning wherever relevant

    2. Please consider changing the current behavior to be like the common one, as I described above.

     Thanks for the fast reply and the good work on Fiddler!

    Eitan

Back to Top