On select node, Treeview jumps to top

3 posts, 0 answers
  1. Tobias
    Tobias avatar
    28 posts
    Member since:
    Jun 2013

    Posted 19 Sep 2013 Link to this post

    Hi folks,
    I have the following problem:
    I have hundreds of entries in my TreeView that's why it scrolls. If I select a scrolled item, the tree jumps back to the top and does not stay on the current node position. The selection is still targeting the correct node.

    If I just expand the node, the view does scroll to the top.

    Update
    If i would set a height property, the tree does not jump.

    Do you have any idea?

    Thanks a lot!

    - Tobi
  2. Pavel R. Pavlov
    Admin
    Pavel R. Pavlov avatar
    1182 posts

    Posted 24 Sep 2013 Link to this post

    Hi Tobias,

    I tried to reproduce the reported behavior with our latest official release on our side and it seems that the code works as expected. Can you please try to reproduce the issue in a separate project and send it over. By doing so we will be able to fully understand your scenario and further investigate the possible reasons behind.

    Thank you for your cooperation.

    Regards,
    Pavel R. Pavlov
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for SILVERLIGHT.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  3. DevCraft banner
  4. Tobias
    Tobias avatar
    28 posts
    Member since:
    Jun 2013

    Posted 24 Sep 2013 Link to this post

    Hi,
    I solved my problem. It was NOT a Telerik issue. Sorry for that.
    The grid row of the tree was set to height='auto'. I set a fix value (or a row span with an additional fixed height row) and the tree does not scroll up.

    Thanks for your reply!

    - Tobias
Back to Top