Numeric FormatString no longer working

3 posts, 0 answers
  1. Gareth
    Gareth avatar
    2 posts
    Member since:
    Mar 2014

    Posted 02 May 2014 Link to this post


    I have a RadMaskedNumericInput set with TextMode = PlainText, and FormatString of "c2". this always used to work, now however I just appears blank. If I use n2 it works but I loose the currency symbol. Worst yet in other cultures n2 is unusable as the decimal place seems to have stopped working correctly.
    What's gone wrong with the latest version?

  2. Gareth
    Gareth avatar
    2 posts
    Member since:
    Mar 2014

    Posted 02 May 2014 in reply to Gareth Link to this post


    I can reproduce this problem using your demo app. It seems to only manifest itself if your culture is not en-us.
    So if you use the maskednumericinput control, change the culture to French for instance, then set mask = "" and formatstring = "c2" you'll get the broken behaviour.
    This problem is on maskednumericinput and maskcurrencyinput when the culture is not en-us.

    When can this be fixed?
  3. DevCraft R3 2016 release webinar banner
  4. Petar Mladenov
    Petar Mladenov avatar
    2882 posts

    Posted 06 May 2014 Link to this post

    Hi Gareth,

    We are aware of this issue and we have previously logged it here. Currently it is under testing. You may download the new internal build which will be releases in a few days. The fix will be also included in the upcoming Q2 Release in mid-June.

    Please excuse us for the inconvenience caused.

    Petar Mladenov
    Check out Telerik Analytics, the service which allows developers to discover app usage patterns, analyze user data, log exceptions, solve problems and profile application performance at run time. Watch the videos and start improving your app based on facts, not hunches.
Back to Top