Not working on Masterpages

5 posts, 1 answers
  1. JeffSM
    JeffSM avatar
    11 posts
    Member since:
    May 2014

    Posted 25 Aug 2014 Link to this post

    Hi,

    It's my first walk through telerik, and I started adding an control to an existing project.

    The problem is that a RadDropDownList don't open when clicked, but is just on MasterPage Content, in an .aspx file it works fine.

    HOW TO FIX?

    I added the necessary controls in the MasterPage.

    and the code that I'm using is on contect page is:

    <%@ Page Title="" Language="C#" MasterPageFile="~/Sistema/SistemaBase.Master" AutoEventWireup="true" CodeBehind="Teste1.aspx.cs" Inherits="AdvocatiNet100.Sistema.Teste1" %>

    <%@ Register TagPrefix="telerik" Namespace="Telerik.Web.UI" Assembly="Telerik.Web.UI" %>

    <asp:Content ID="Content7" ContentPlaceHolderID="ContentPlaceHolder1" runat="server">
        <asp:ObjectDataSource ID="dsDados" runat="server" SelectMethod="LoadDados" TypeName="AdvocatiNet100.CompromissoINC"></asp:ObjectDataSource>

        <label for="cboTipoIMG">Tipo do compromisso:</label><br />
        <telerik:RadDropDownList ID="cboTipoIMG" runat="server" DataSourceID="dsDados" DataTextField="FDescricao" DataValueField="ID">

            <ItemTemplate>
                <table>
                    <tr>
                        <td>
                            <img src="http://www.menphissi.com.br/v4/agenda/<%# DataBinder.Eval(Container.DataItem, "FIcone")%>.png" width="16" height="16" alt="" />
                        </td>
                        <td>
                            <%# DataBinder.Eval(Container.DataItem, "FDescricao")%>
                        </td>
                    </tr>
                </table>
            </ItemTemplate>
        </telerik:RadDropDownList>
        <telerik:RadAjaxManagerProxy ID="AjaxManagerProxy1" runat="server">
            <AjaxSettings>
                <telerik:AjaxSetting AjaxControlID="cboTipoIMG">
                </telerik:AjaxSetting>
            </AjaxSettings>
        </telerik:RadAjaxManagerProxy>

    </asp:Content>












  2. Answer
    Shinu
    Shinu avatar
    17764 posts
    Member since:
    Mar 2007

    Posted 26 Aug 2014 in reply to JeffSM Link to this post

    Hi JeffSM,

    From your code I have noticed that you are not setting Updated Controls in the RadAjaxManagerProxy. Try to set the UpdatedControls in the content page as follows. Also please make sure that you have included RadAjaxManager in the Master Page.

    Content Page :
    <telerik:RadAjaxManagerProxy ID="AjaxManagerProxy1" runat="server">
        <AjaxSettings>
            <telerik:AjaxSetting AjaxControlID="cboTipoIMG">
                <UpdatedControls>
                    <telerik:AjaxUpdatedControl ControlID="cboTipoIMG" />
                </UpdatedControls>
            </telerik:AjaxSetting>
        </AjaxSettings>
    </telerik:RadAjaxManagerProxy>

    Thanks,
    Shinu.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. JeffSM
    JeffSM avatar
    11 posts
    Member since:
    May 2014

    Posted 26 Aug 2014 in reply to Shinu Link to this post

    Not working yet.

    Is there another suggestion?
  5. JeffSM
    JeffSM avatar
    11 posts
    Member since:
    May 2014

    Posted 26 Aug 2014 in reply to Shinu Link to this post

    Hi, I too added :

     <telerik:RadAjaxPanel ID="RadAjaxPanel1" runat="server">

    as the telerik demo, but still do not work.

    Any suggestions?
  6. JeffSM
    JeffSM avatar
    11 posts
    Member since:
    May 2014

    Posted 26 Aug 2014 in reply to JeffSM Link to this post

    Solved, I had an reference to AJAXToolkit yet. After removing the tag it worked just fine.

    Thansk any way Shinu.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017