Not all files are pushed to GitHub

10 posts, 0 answers
  1. Christian
    Christian avatar
    24 posts
    Member since:
    Sep 2008

    Posted 02 Oct 2012 Link to this post

    OK,

    this is the repo in question:
    https://github.com/ChristianWeyer/MobileTODOIcenium/tree/master/MobileTODOsIcenium


    As you can see from the attached screenshot not all files have been pushed - hm.

    Thanks,
    -Christian
  2. Stefan Dobrev
    Admin
    Stefan Dobrev avatar
    790 posts

    Posted 03 Oct 2012 Link to this post

    Thanks for pointing this our, Christian. We have it already logged in our bug tracking system and a fix is on its way.

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Pluralsight.
  3. Christian
    Christian avatar
    24 posts
    Member since:
    Sep 2008

    Posted 03 Oct 2012 Link to this post

    OK - when will that fix show up? Because now it is pretty useless? ;)
  4. Stefan Dobrev
    Admin
    Stefan Dobrev avatar
    790 posts

    Posted 04 Oct 2012 Link to this post

    The fix will be available in the next public release which is coming really soon. Till then you can try to delete the index.html from the project navigator and then create a new html file.

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Pluralsight.
  5. Christian
    Christian avatar
    24 posts
    Member since:
    Sep 2008

    Posted 04 Oct 2012 Link to this post

    I will wait for now...
  6. Stefan Dobrev
    Admin
    Stefan Dobrev avatar
    790 posts

    Posted 05 Oct 2012 Link to this post

    My suggestion is to delete the file and at it back again. It will take you about a second to do so. :)

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Pluralsight.
  7. Christian
    Christian avatar
    24 posts
    Member since:
    Sep 2008

    Posted 05 Oct 2012 Link to this post

    Yes, sir! :) All is good now.
  8. dave
    dave avatar
    3 posts
    Member since:
    Aug 2005

    Posted 24 Jan 2013 Link to this post

    Is this fixed yet? I have a lot of files that are not being pushed and deleting/creating them again will take a long time.
    -dave
  9. Ivan
    Admin
    Ivan avatar
    111 posts

    Posted 25 Jan 2013 Link to this post

    Hello,

    Our assumption is you have hit the bug that when adding external files to your project (either via drag and drop from Windows Explorer or via the "Add/Existing Files" menu option) the added files are not staged correctly in the local version control repository, so you cannot commit them and push to the remote GitHub repository. I have just verified that the problem does not exist with the latest version of Graphite available for download at www.icenium.com. The fix does not affect existing broken projects however. You need to remove and add the unstaged files manually:

    1. Go to the Dashboard page and export your project as a ZIP file.
    2. Extract the ZIP file and verify it contains all the necessary files.
    3. Remove all the unstaged files from Project Explorer in Graphite.
    4. Drag and drop your local copies of the files in Project Explorer.
    5. Commit and push the changes - this time it should be successful.

    Please, accept our apologies for the caused inconvenience.

    Kind regards,
    Ivan
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Pluralsight.
  10. dave
    dave avatar
    3 posts
    Member since:
    Aug 2005

    Posted 25 Jan 2013 Link to this post

    That worked!
    Thanks, dave
Back to Top