Nodes not lined up.

3 posts, 0 answers
  1. Daniel
    Daniel avatar
    2 posts
    Member since:
    Apr 2012

    Posted 13 Apr 2012 Link to this post

    I am probably missing something incredibly simple. I am retrieving a datatable and binding it to the org chart. I set the top level nodes to have a parent of null, and then the rest are set up referencing their parent. The nodes all render in the correct hierarchy, but the alignment is screwed up.

    Screenshot attached.
  2. Daniel
    Daniel avatar
    2 posts
    Member since:
    Apr 2012

    Posted 16 Apr 2012 Link to this post

    After playing around this weekend, I noticed the org chart does line up properly under IE8 Standards mode, but when IE is in quirks, or when using Chrome, there are still problems with lining things up. 
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Peter Filipov
    Admin
    Peter Filipov avatar
    1028 posts

    Posted 18 Apr 2012 Link to this post

    Hi Daniel,

    The RAD Asp.Net Ajax controls are supported under IE 6 +. Quick mode option is used to open pages which are working correct only under IE 5,4 (it forces the browser to work like its older versions). Therefore we do not support our controls under Quirks mode.
    Regarding the problematic behavior under Chrome, I tested our online demos and everything is working fine. Could you please send me an example (or live URL), where I can investigate the RadOrgChart appearance ?

    Kind regards,
    Peter Filipov
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top