No markers for IE11

10 posts, 0 answers
  1. miksh
    miksh avatar
    275 posts
    Member since:
    Nov 2006

    Posted 24 Jun 2014 Link to this post

    Nice control, thanks!
    I noticed that there is no markers as well as navigation buttons (up/down/right/left) displayed in IE11 at http://demos.telerik.com/aspnet-ajax/map/examples/overview/defaultcs.aspx.
    Could you look into?
  2. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 25 Jun 2014 Link to this post

    Hello Michael,

    The described demo is showing the markers as expected under IE11. You can see the results on my end with this screenshot

    If you still have issues with the markers, please provide more details how this problem is encountered. You can verify if the compatibility mode is enabled, this could caused due to some browser limitation when in compatibility mode. 

    Regards,
    Ianko
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. miksh
    miksh avatar
    275 posts
    Member since:
    Nov 2006

    Posted 25 Jun 2014 in reply to Ianko Link to this post

    See attached. It's IE11 on Windows 7.
    Console errors:
    ​CSS3117: @font-face failed cross-origin request. Resource access is restricted.
    File: TelerikWebUI.woff

    CSS3114: @font-face failed OpenType embedding permission check. Permission must be Installable.
    File: TelerikWebUI.ttf
  5. Misho
    Admin
    Misho avatar
    129 posts

    Posted 25 Jun 2014 Link to this post

    Hello,

    We had a known CORS issue with our CDN resources. It's already fixed but since you've requested those resources before our fix they are most probably cached by your browser. Could you please try clearing your browser cache using CTRL + F5. In addition could you please say whether you are testing RadMap on our online demos or on your personal website?

    Looking forward to your reply.

    Regards,
    Misho
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  6. miksh
    miksh avatar
    275 posts
    Member since:
    Nov 2006

    Posted 25 Jun 2014 in reply to Misho Link to this post

    ctrl+f5 didn't help. I use online demo page http://demos.telerik.com/aspnet-ajax/map/examples/overview/defaultcs.aspx
  7. Misho
    Admin
    Misho avatar
    129 posts

    Posted 26 Jun 2014 Link to this post

    Hello,

    Could you please try to clear your browser cache using the approach described in this article?

    Regards,
    Misho
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  8. miksh
    miksh avatar
    275 posts
    Member since:
    Nov 2006

    Posted 26 Jun 2014 in reply to Misho Link to this post

    Cleaned temp files, cookies and website data - didn't help, same CORS errors.
    Fyi, I tried in several computer in our company, and eventually from absolutely different location with brand new Windows 8.1 install - same issue.
    Perhaps, you are ok in Telerik subnet.
  9. Logan
    Logan avatar
    23 posts
    Member since:
    Jan 2012

    Posted 29 Jun 2014 in reply to Misho Link to this post

    Had the same issue with the markers demo, ctrl-f5 worked for me on Win8.1 x64.  Thank you.
  10. Misho
    Admin
    Misho avatar
    129 posts

    Posted 30 Jun 2014 Link to this post

    Hi Michael,

    I've invalidated the TelerikWebUI.woff resource in our CDN which means that the cache on the server is supposed to be cleared. Could you please try obce again to clear your browser cache and if the issue is still happening to send the output of the browser console for this resource together with the response headers and more precisely the value of the "Access-Control-Allow-Origin". I've created a screenshot showing how to obtain this information:
    http://screencast.com/t/skIeq6BW

    Thank you in advance.

    Best Regards,
    Misho
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  11. miksh
    miksh avatar
    275 posts
    Member since:
    Nov 2006

    Posted 02 Jul 2014 in reply to Misho Link to this post

    It works now. I didn't need to reset anything so the problem perhaps was at your side.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017