no events when deployed in windows phone

3 posts, 0 answers
  1. Alan Mosley
    Alan Mosley avatar
    200 posts
    Member since:
    Apr 2010

    Posted 07 Oct 2014 Link to this post

    I have connected my windows phone also windows phone emulatror but there is no data-init event fired.
    this event fires in simulator
    Thanks
  2. Alan Mosley
    Alan Mosley avatar
    200 posts
    Member since:
    Apr 2010

    Posted 07 Oct 2014 in reply to Alan Mosley Link to this post

    After further test, it seems that the events work if the JavaScript in on page, I worked out from there that it was because I was using typescript, and the js files were not included in project, including them in project fixed this.
    in other projects this step is not necessary.
    Thanks
  3. Martin Yankov
    Admin
    Martin Yankov avatar
    177 posts

    Posted 10 Oct 2014 Link to this post

    Hi Alan,

    I am glad that you were able to solve this yourself.

    The Kendo UI TypeScript definitions only complement the Kendo UI widgets and controls and enable strongly-typed definitions. But for Kendo UI widgets to work in the first place, you need the package files included and referenced in your project.

    Do not hesitate to ask should you have any other questions.

    Regards,
    Martin Yankov
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
Back to Top