No Debug Directory Section

2 posts, 0 answers
  1. Rob
    Rob avatar
    2 posts
    Member since:
    Jul 2013

    Posted 24 Mar Link to this post

    Hi There,

    I am attempting to generation PDBs for some third party component (not Telerik :-)) and am getting a No Debug Directory Section error with the detail saying "PDB for assembly GrapeCity.ActiveAnalysis.Web.dll cannot be generated because the Debug Directory PE section is missing or empty."  Can anyone tell me what this means and whether there is a way out of this problem?



  2. Alexander
    Alexander avatar
    79 posts

    Posted 28 Mar Link to this post


    About "Debug Directory Section" you can find very detailed information over the Internet.

    Very shortly what make sense in this case - some assemblies out there are compiled without adding any debug information, which is usually stored in the Debug Directory PE Section. For those assemblies, we cannot generate PDB yet, because we need such debug information.

    We have a task to make PDB generation for those assemblies possible on our list and if you want to increase its priority, you can add a feature suggestion in our UserVoice system. By doing that you enable other people to vote for this suggestion. More the votes, more the priority.

    That being said, I can tell you that you can use Telerik's JustCode to debug into assemblies with missing Debug Directory Section. You can find more information here.

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. DevCraft banner
Back to Top