Next Silvelight Control Release?

15 posts, 0 answers
  1. Jaime
    Jaime avatar
    32 posts
    Member since:
    Sep 2008

    Posted 21 Jan 2009 Link to this post

    Hi!,

    When is due the next release of the Silverlight control Suite?

    With all do respect. The December Release is unbeareble! Inmediatly we uploaded the december release to the Dev. Enviroment we started experiencing heavy Blend incompatibilities and application crashes. We had to roll back to the RTW release.

    When is the Full Blend Theming Support be available?
    Is there a way to properly report this issues to you?


    Best Regards
  2. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 21 Jan 2009 Link to this post

    Jamie, I know your question was address to Telerik team regarding the next update, but I wanted to see if you could share or point out what problems and which controls you encounter problems with.
    a) In case others may have a solution to that
    b) you can share your findings to avoid same problem for us
    c) reporting your issues to telerik.

    Thanks
    ..Ben

    p.s. As a Silverlight Insider, I have seen telerik team working closely with Expression team to resolve some of the issues with Expression. Just wanted you to know!
  3. DevCraft banner
  4. Jaime
    Jaime avatar
    32 posts
    Member since:
    Sep 2008

    Posted 21 Jan 2009 Link to this post

    Hi Ben,

    Thanks for the quick response.

    Of course, I'll be glad to submmit issues. Is there a webpage to do that, or do we use the Forum, beacuse we would need to post stacktraces and Images.

    Best Regards.


  5. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 21 Jan 2009 Link to this post

    Hi Jamie;

    If you open up a support ticket, it will be met and followed up by a specialist, however other developers will not benefits from your findings.

    The way that I usually peruse this, is that I first make a detail post here with bullet points and this way others may add more comments as well. And then telerik team will either respond directly on the forum or they will move it to support ticket. But I would start here.

    Hope this helps!
    ..Ben
  6. Jaime
    Jaime avatar
    32 posts
    Member since:
    Sep 2008

    Posted 21 Jan 2009 Link to this post

    Well, the main issue es that December Controls don't render on Microsoft Blend. (RTW do).

    Here is a link for the screenshot.
    Blend Render Screen Shot 

    As said before RTW works fine, we suspect from the the telerik DragDrop, because in runtime, we get an AgParser error.
  7. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 21 Jan 2009 Link to this post

    Jamie, are you up to date with latest Blend updates? I used to see that kind of errors with older version of Blend and it had nothing to do with Telerik controls. Sometimes, I had to exit out of Blend, restart the computer and the error would go away. But since the latest SP from Blend, I have not seen that. Secondly, do you have enough memory on the machine? I also noticed that error on one of my machines that was low on memory.

    I'm just trying give some things to look into!
  8. Jaime
    Jaime avatar
    32 posts
    Member since:
    Sep 2008

    Posted 22 Jan 2009 Link to this post

    Hi!,

    the current version that we are running is Blend 2 SP1 (2.1.1760.0 not aware is there's a newer one.) in Spanish & English. The machines have 2 Gigs of Ram, Run Windows 2008 for Dev. and Windows XP for Design. The project is relatively Big (24+ silverlight Projects). As said before, RTW works relatively fine, it does render just by rolling back the control reference.

    Sometimes we get that error, other tiems Blend will simply not render Anything (With December Release).

    Best Regards

    Jaime Bula
  9. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 22 Jan 2009 Link to this post

    Ok, I just checked the Blend version and seems like you (the Spanish version) have the same as US version. At least, I know you're up to date. I'll the team to jump in.

    Good luck!
    ..Ben
  10. Jaime
    Jaime avatar
    32 posts
    Member since:
    Sep 2008

    Posted 27 Jan 2009 Link to this post

    Hi!,

    I'd recalled you said that memory could be the issue, I think you might be right. On a fresh reboot controls render Fine (December Release), BUT AFTER 4 BLEND TABS, pages either stop rendering, o start throwing Exceptions. Dev Machines are Windows 2008 Standard with 2 Gigs of Ram (Other tool are run at the same time: Sql Server Management Studio 2008, Visual Studio, Team Explorer, Word and Outlook, Messenger, IE 7 etc.)

    The project is also big, there are 14 independent silverlight projects, that actually share assemblies and controls. The Whole solution is 32+ VS Projects.

    What I still wonder is that with the RTW this issue isn't happening. Any ideas?, or we should just add more Ram.

    Best Regards.

    Jaime.

  11. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 27 Jan 2009 Link to this post

    Hi Jamie;

    I think the memory issue might be your problem, try to add more memory and hopefully it will solve it.
  12. Jaime
    Jaime avatar
    32 posts
    Member since:
    Sep 2008

    Posted 12 Feb 2009 Link to this post

    Hi,

     

    We upgraded all machines to 4 gigs, same problem.

     

    ¿Any other recomendation?


    Best Regards.

  13. Hristo
    Admin
    Hristo avatar
    832 posts

    Posted 13 Feb 2009 Link to this post

    Hello Jaime,

    Can you send us simple project demonstrating this issue. It will be much easier for us to investigate it if we have this project.
    Also I want to point you that in the next official release all controls will be with much better integration with Blend 2.

    Best wishes,
    Hristo
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  14. Jaime
    Jaime avatar
    32 posts
    Member since:
    Sep 2008

    Posted 13 Feb 2009 Link to this post

    Hi, on sample solutions it works, I don't know if it's due to the size of the project. What I can do is enable a Dev Virtual machine with the whole current project so that you can log in and check it out.

    Best Regards.

    Jaime.
  15. Jaime
    Jaime avatar
    32 posts
    Member since:
    Sep 2008

    Posted 16 Mar 2009 Link to this post

    Hi,

    We discovered that what was causing the problem was a project in our solution. I'll get back when we have it analyzed. 
  16. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 16 Mar 2009 Link to this post

    Jaime, this is great news to see you're getting closer to your findings. When you're certain, please share your findings with others.
    Good luck!

    ..Ben
Back to Top
DevCraft banner