MySQL setup

6 posts, 0 answers
  1. Chris Douglass
    Chris Douglass avatar
    6 posts
    Member since:
    Sep 2005

    Posted 25 Aug 2010 Link to this post

    I'm trying to get the ORM trial to connect to a mySQL instance but I don't see the mySQL drivers listed in the Add Data Source dialog when I try to create "New Connection" in the "New Domain Model" wizard.  But, the mySQL drivers are listed (I'm using the ones from www.devart.com the dotConnect drivers for mySQL b/c the ones from MySQL.com don't show up in VS 2010 Pro even after install) when I open the Add Data Connection from Server Explorer.  I can create a connection to the mySQL instance with no problem using ServerExplorer and the Add Data Source dialog.

    I'm using VS 2010 Pro, maybe that's an issue for the newest OpenAccess ORM package?  

    Does anyone have a reference or sample on how to connect ORM to mySQL in VS 2010?

    Thanks,
    Chris
  2. Alexander
    Admin
    Alexander avatar
    727 posts

    Posted 26 Aug 2010 Link to this post

    Hi Chris Douglass,

    I am afraid that the Devart dotConnect driver is not currently supported by OpenAccess but the MySql Connector .Net is. The latest beta builds with version 6.3.* of Connector .Net support Visual Studio 2010, probably you have installed one of the previous official builds. Hope that helps.

    Regards,
    Alexander
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft banner
  4. Harald Bacik
    Harald Bacik avatar
    13 posts
    Member since:
    Aug 2009

    Posted 12 Jul 2011 Link to this post

    Hey

    Any plans, that the Devart's drivers will be accepted by ORM Designer?
    I like there tools also.

    THX
  5. Alexander
    Admin
    Alexander avatar
    727 posts

    Posted 13 Jul 2011 Link to this post

    Hello Harald Bacik,

    I am sorry to disappoint you but currently we do not have plans to support any other .Net providers for MySQL.

    Regards,
    Alexander
    the Telerik team

    Register for the Q2 2011 What's New Webinar Week. Mark your calendar for the week starting July 18th and book your seat for a walk through of all the exciting stuff we will ship with the new release!

  6. Sascha
    Sascha avatar
    1 posts
    Member since:
    Jul 2013

    Posted 09 Jul 2014 Link to this post

    Hello!

    If have the same problem with VisualStudio 2008.

    I'm using Telerik OpenAccess 2013.3.121
    And I installed MySql net connector 6.8.3.0

    I try to create a new Domain Model and select "MySQL" as Backend. In the next form I tried to click on the "add new connection" Button but i get the following Error: 
     "no data source are available"

     Does any one have a solution for this problem?

  7. Kristian Nikolov
    Admin
    Kristian Nikolov avatar
    206 posts

    Posted 09 Jul 2014 Link to this post

    Hello Sascha,

    As of Connector/NET 6.7.x there is no Visual Studio integration provided in the MySql drivers. This is the reason for the behavior you are experiencing. The Visual Studio integration has been separated into MySql for Visual Studio.

    With this in mind we recommend you install MySql for Visual Studio - it should be available in the MySql windows installer. Alternatively, your could revert to an older version of the driver such as Connector/NET 6.6.6 for example.

    I hope this helps. Feel free to use our forums should you have additional questions.

    Regards,
    Kristian Nikolov
    Telerik
     
    OpenAccess ORM is now Telerik Data Access. For more information on the new names, please, check out the Telerik Product Map.
     
Back to Top
DevCraft banner