My table layout does not seem to work when using RadSplitter

2 posts, 0 answers
  1. hkdave95
    hkdave95 avatar
    245 posts
    Member since:
    Nov 2006

    Posted 23 Sep 2007 Link to this post

    Hi

    I have a table layout which should display two black tile graphics as side borders with a light colour tile graphics for the body.

    However the right hand tile graphics does not display despite all my efforts.

    The aspx for the whole page is ...
    <%@ Page Language="VB" AutoEventWireup="false" CodeFile="Default.aspx.vb" Inherits="_Default" %> 
     
    <%@ Register Assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" 
        Namespace="System.Web.UI" TagPrefix="asp" %> 
     
    <%@ Register Assembly="Telerik.Web.UI" Namespace="Telerik.Web.UI" TagPrefix="telerik" %> 
     
    <%@ Register Assembly="RadMenu.Net2" Namespace="Telerik.WebControls" TagPrefix="radM" %> 
     
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 
     
    <html xmlns="http://www.w3.org/1999/xhtml">  
    <head runat="server">  
        <title>the-dl-outlet.co.uk</title> 
        <link type="text/css" href="resources/main.css" rel="Stylesheet" /> 
    </head> 
    <body id="bodyDefault" runat="server">  
        <form id="formDefault" runat="server">  
            <telerik:RadScriptManager ID="rsmDefault" runat="server">  
            </telerik:RadScriptManager> 
            <telerik:RadAjaxManager ID="ramDefault" runat="server">  
            </telerik:RadAjaxManager> 
            <telerik:RadAjaxLoadingPanel ID="ralpDefault" runat="server" Height="75px" Width="75px">  
                <asp:Image ID="imgLoading" runat="server" AlternateText="Loading..." ImageUrl="~/RadControls/Ajax/Skins/Default/Loading.gif" /> 
            </telerik:RadAjaxLoadingPanel> 
            <telerik:RadWindowManager ID="rwmDefault" runat="server">  
            </telerik:RadWindowManager> 
            <div id="divMain" runat="server" class="divMain">  
                <center> 
                    <telerik:RadSplitter ID="rsDefault" runat="server" width="850px" height="100%" VisibleDuringInit="true">  
                        <telerik:RadPane ID="rpDefault" runat="server" width="850px" height="100%" Scrolling="none">  
                            <table style="width: 850px; height: 100%;">  
                                <tr style="width: 850px;">  
                                    <td style="background-image: url('images/black-tile.gif'); width: 90px;">  
                                        <img src="images/black-tile.gif" alt="" style="width: 90px;"/>  
                                    </td> 
                                    <td style="width: 670px;">  
                                        <telerik:RadSplitter ID="rsDefaultPage" runat="server" width="670px" height="100%" Orientation="Horizontal" BorderSize="0">  
                                            <telerik:RadPane ID="rpDefaultHeader" runat="server" width="670px" height="100px" Locked="true" Scrolling="none" BorderWidth="0">  
                                            </telerik:RadPane> 
                                            <telerik:RadPane ID="rpDefaultPage" runat="server" width="670px" height="100%" Scrolling="none" BorderWidth="0">  
                                            </telerik:RadPane> 
                                            <telerik:RadPane ID="rpDefaultFooter" runat="server" width="670px" height="50px" Locked="true" Scrolling="none" BorderWidth="0" CssClass="rpDefaultFooter">  
                                            </telerik:RadPane> 
                                        </telerik:RadSplitter> 
                                    </td> 
                                    <td style="background-image: url('images/black-tile.gif'); width: 90px;">  
                                        <img src="images/black-tile.gif" alt="" style="width: 90px;" /> 
                                    </td> 
                                </tr> 
                            </table> 
                        </telerik:RadPane> 
                    </telerik:RadSplitter> 
                </center> 
            </div> 
        </form> 
    </body> 
    </html> 
     

    NB: if I remove the following from the lowest level table the page is displayed as I wish ...
                                            <telerik:RadPane ID="rpDefaultHeader" runat="server" width="670px" height="100px" Locked="true" Scrolling="none" BorderWidth="0">  
                                            </telerik:RadPane> 
                                            <telerik:RadPane ID="rpDefaultPage" runat="server" width="670px" height="100%" Scrolling="none" BorderWidth="0">  
                                            </telerik:RadPane> 
                                            <telerik:RadPane ID="rpDefaultFooter" runat="server" width="670px" height="50px" Locked="true" Scrolling="none" BorderWidth="0" CssClass="rpDefaultFooter">  
                                            </telerik:RadPane> 
     

    NB: I am using Vista 64 Framework .NEt 2.0 VS 2005

    You can view the site at http://daresoft.no-ip.co.uk/the-dl-outlet

    Kind Regards

    David
  2. hkdave95
    hkdave95 avatar
    245 posts
    Member since:
    Nov 2006

    Posted 25 Sep 2007 Link to this post

    Hi

    I got round my problem by removing the parent splitter.

    Kind Regards

    David
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top