Multilingual Spell checker not working on multiple RadHtmlField controls

5 posts, 1 answers
  1. George Chiang
    George Chiang avatar
    2 posts
    Member since:
    Jul 2009

    Posted 28 Jun 2010 Link to this post

    Hello,

    I am running RadEditor for Sharepoint version with 5.6.2.0 assembly and have enabled multiingual dictionaries (by editing the ToolsFile.xml) for the spell checker.
    The functionality works fine for the first Telerik RadEditor control on the page in authoring mode (see attached screenshot radHtml1.jpg), however if on all the subsquent RadEditor controls, the language selection dropdown for the Spell checker is blank. (see radHtml2.jpg

    Is this a bug in the control ? or am I doing something wrong.

    Thanks.

     

  2. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 29 Jun 2010 Link to this post

    Hi George,

    Could you confirm that the problem behavior occurs in list scenarios such as list, wiki, blog? If this is the case, you need to apply the changes you made in the ToolsFile.xml file in ListToolsFile.xml as well.

    If this is not the case, could you provide me with your ConfigFile.xml, ListConfigFile.xml, ToolsFile.xml, ListToolsFile.xml. A step by step scenario of how to reproduce the issue will be helpful as well.

    Thank you.


    Sincerely yours,
    Stanimir
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items

  3. George Chiang
    George Chiang avatar
    2 posts
    Member since:
    Jul 2009

    Posted 29 Jun 2010 Link to this post

    Hello,

    I am only interested in getting the RadEditor control to work on SharePoint WCM projects (RadHtmlField control).

    Steps to reproduce:

    1. add languages to ToolsFile.xml to be used in spell checker (en-US & fr-FR)
    2. Go to a Sharepoint publishing page with multiple Telerik RadHtmlField and Edit the page
    3. Observe the first RadHtmlField control and see the added languages appear in the spell checker dropdown
    4. Observe the subsequent RadHtmlField controls and the spell checker dropdown is empty

    Please tell me who to send the files to, the forum wouldn't let me attach xml files (i've even renamed them to jpg) here and I don't have a direct email address to send the files to.
  4. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 30 Jun 2010 Link to this post

    Hi George,

    You can send me the files to stanimir.patarinski@telerik.com. I will use them for my test and advise you further.

    Kind regards,
    Stanimir
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Answer
    Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 01 Jul 2010 Link to this post

    Hello George,

    The described problem is a known issue when you set the UseSharedToolbar to true. You have two options here.

    1. Do not use the UseSharedToolbar="true" setting.
    2. Update to the latest version of RadEditor for MOSS 5.7.3, where this issue is fixed. You can find the upgrade instructions in the following online hep article: http://www.telerik.com/help/aspnet-ajax/upgrade_to_a_newer_version_of_radeditor_for_moss.html


    Greetings,
    Stanimir
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top