Multi-Language supported?

4 posts, 0 answers
  1. Iros
    Iros avatar
    2 posts
    Member since:
    Jul 2016

    Posted 21 Aug Link to this post

    When I try to use calendar to display Simple-Chinese, Traditional-Chinese, Korea... then it will cause JNI exception, please see attachments.

    Is there any way to correct setting up calendar widget or it's not ready to support multi-language?

    Thanks.

  2. Vladislav
    Admin
    Vladislav avatar
    275 posts

    Posted 24 Aug Link to this post

    Hello Germos,

    Thank you for contacting us.
    Unfortunately we are unable to reproduce the described problem based on the information provided.
    Is it possible to provide more info about your setup/project. A sample project (or just the relevant part of your original one) demonstrating the issue will be great.

    Do you get this exception with other cultures (en, fr, etc.)?
    What is the Android API version of the device/emulator where this exception is observed?
    What is the exact version of our controls used?

    Hopefully with this additional information we will be able to reproduce the problem.

    Thank you in advance.

    Regards,
    Vladislav
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. DevCraft banner
  4. Iros
    Iros avatar
    2 posts
    Member since:
    Jul 2016

    Posted 25 Aug in reply to Vladislav Link to this post

    I made a sample project, the sample result as shown on zipped file.

    The language change to Traditional-Chinese will cause fail.
    Change to english, french are ok.

    It might be a UTF-8 or Unicode problem?

    Pls see the complete project: https://docs.google.com/document/d/1lw9vbmf2ga_lRgNuJUavi7I2ch3yrnMINB5G61Qog6g/edit

     

    Thank you

  5. Vladislav
    Admin
    Vladislav avatar
    275 posts

    Posted 26 Aug Link to this post

    Hi Germos,

    Thank you for the additional information and sample project provided.
    We were able to reproduce it locally, but we noticed that you are using outdated version of our controls (2016.2.708.230). We recently released a newer version (2016.3.822.231) which should be available under your account in the "Betas" section. And with this version (which targets the latest version of XamarinForms 2.3.1.114) the sample project works properly with these cultures.

    Is it possible for you to try your project with the newer version of our controls?

    Regards,
    Vladislav
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top
DevCraft banner