msi installer for Telerik UI for NativeScript

5 posts, 0 answers
  1. Kirsten
    Kirsten avatar
    2 posts
    Member since:
    Oct 2016

    Posted 15 Oct Link to this post

    I have problem installing the trial UI NativeScript with msi installer.
    I got the error:
    Setup interrupted
    Download Node.js

    I already got Node.js 4.2.1 installet, because I am already working with NativeScript. 

  2. Nikolay Iliev
    Admin
    Nikolay Iliev avatar
    94 posts

    Posted 17 Oct Link to this post

    Hi Kirsten,

    We have tested a fresh installation of Telerik-UI with node 4.2.1 and the installation passed as expected on our side.

    As a possible solution, you can try to remove a previous installed versions of Telerik-UI and make sure that your node is installed per the user that is currently logged in (run node --version to ensure the current user has installed node). Are you node.js installed per user or  per machine!?

    Another possible approach is to use a node version manager , which will allow you to use multiple versions of node.js on the same machine. Good Node package manager for Windows can be found here. This way you can install the latest version and switch when needed to the older versions.

    Regards,
    Nikolay Iliev
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Jeric Paul
    Jeric Paul avatar
    2 posts
    Member since:
    Oct 2016

    Posted 17 Oct in reply to Nikolay Iliev Link to this post

    Hi Nikolay,

    I'm having this error too; I haven't installed Telerik-UI before with this .msi installer.

    On Windows 10, I have installed nvm-windows (from your link) and tried:

    a) 5.12, 4.6 and 4.2.1 (all 64-bit): installer not recognizing node

    b) 4.2.1 (32-bit): installer not recognizing node

    On all occasions, node is verified working with the target versions (node --version) before running the .msi installer

     

  4. Kirsten
    Kirsten avatar
    2 posts
    Member since:
    Oct 2016

    Posted 17 Oct Link to this post

    I solved my problem.
    I had 2 harddiskes on windows, C: and E: 
    Node.js was installed on C. 
    When I installed Telerik-UI, it was no way to choose on which hard drive the msi installer was going to install it. 
    I tried therefor to uninstall node.js from C: and install it on E: instead.
    After that I could install Telerik-UI without problems.
  5. Nikolay Iliev
    Admin
    Nikolay Iliev avatar
    94 posts

    Posted 18 Oct Link to this post

    Hi Kirsten,

    Glad to hear that you have managed to solve your problem!
    Also, I want to thank you for reporting back this behaviour - I will directly follow the provided information and solution to the developer's team in order to fix this issue as soon as possible.

    Regards,
    Nikolay Iliev
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top