MonthViewPanel not updating after customising style

4 posts, 1 answers
  1. Robin
    Robin avatar
    2 posts
    Member since:
    Oct 2016

    Posted 10 Oct 2016 Link to this post


    We are using version 2016.1.217.40 of the Telerik.Windows.Controls.Input dll and whenever we create a custom style (via copy option in Expression Blend) it breaks the Calendar Panel.

    When I say breaks, if you attempt to scroll through the months using the left or right buttons it doesn't refresh the days, i.e. the week numbers stay the same.

    If we don't override the style it all works fine.  Note, at this point we are not changing anything in the style, we are simply copying it as is.

    This did work ok on the 2013.3.1016.40 version.

    I have also tried the same on the 2016.3.914.40 version and it also does not work.

    Is there anything extra that needs to be done to maintain the functionality when overriding the default styles?

    Kind regards


  2. Answer
    Martin avatar
    86 posts

    Posted 13 Oct 2016 Link to this post

    Hello Robin,

    The case you are describing is a known problem, which we have reported to Microsoft. The issue is logged  here in our feedback portal where there is stated a proposed workaround/fix.

    Or you can copy the style from the theme xaml directly rather than extract it through Blend.

    Telerik by Progress
    Do you need help with upgrading your AJAX, WPF or WinForms project? Check the Telerik API Analyzer and share your thoughts.
  3. Robin
    Robin avatar
    2 posts
    Member since:
    Oct 2016

    Posted 13 Oct 2016 in reply to Martin Link to this post

    Thanks Martin,

    That has solved the issue perfectly.


  4. Nick
    Nick avatar
    3 posts
    Member since:
    Jan 2011

    Posted 4 days and 4 hours ago Link to this post

    The workaround posted doesn't work when you use the new Material theme (which also suffers the same bug).


    I should note also, that this wasn't always a bug. Leaving those 3 attributes in worked fine in the 2013 version (I recently did an update from 2013-2016, which went surprisingly smooth)

Back to Top