Modal RadWindow not showing

4 posts, 0 answers
  1. David Penny
    David Penny avatar
    174 posts
    Member since:
    Jun 2006

    Posted 08 Dec 2010 Link to this post

    Hi,

    I have a number of RadGrid controls which edit detail records using RadWindow.  This all works great until I change the Grid so that it is not paged, and the grid displays enough rows to require scrolling down through the window.

    When this happens and I used the Edit link on the grid, the RadWindow opens in modal form but it is displayed somewhere off the page and so the system hangs.  If I edit a record without scrolling down the window opens as expected.

    I have tried modifying css with in my App_Themes\Stylesheet.css file:
    .RadWindow {top: 0px!important; left: 0px!important;}

    I have also tried adding the following javascript after window open:

    ow.autoSize();

     

    ow.moveTo(0, 0);

    ow.Minimize();

    ow.Maximize();

    In all cases the window fails to appear and the page becomes locked.

    I am using ther 2010 Q3 release, but this behavour also showed in previous releases.  Any help appreciated.

    David Penny

  2. Cori
    Cori avatar
    562 posts
    Member since:
    Jul 2010

    Posted 09 Dec 2010 Link to this post

    Hello David,

    What is your RadWindow/RadWindowManager declaration look like? Are you setting the OffsetElementID? Perhaps, that could be the reason you have to scroll when you turn off paging on the RadGrid.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. David Penny
    David Penny avatar
    174 posts
    Member since:
    Jun 2006

    Posted 09 Dec 2010 Link to this post

    Hi Cori,

    Radwindow definition is:

    <telerik:RadWindowManager ID="RadWindowManager1" runat="server" 
        Behaviors="Default" InitialBehaviors="None"
        Left="0" Top="0" ReloadOnShow="True">
    </telerik:RadWindowManager>

    It's not that I have to scroll the RadWindow once opened, it's that after scrolling down through the GridView, when the window is opened is appears off the page somewhere.  I have looked at the properties and it seems to say the top left is 0,0 but the window does not show and the screen is hung because it's modal.

    Dave Penny
  5. David Penny
    David Penny avatar
    174 posts
    Member since:
    Jun 2006

    Posted 09 Dec 2010 Link to this post

    Fixed it!

    The line added to my stylesheet:
    .RadWindow {top: 0px!important; left: 0px!important;}
    was causing the window always to open at 0,0 - but I had scrolled down the page.

    The odd thing is, this was added to prevent pages appearing in the wrong place when scrolling down a Scheduler view, when the window was being opened half way down the page.

    Removing this from the global stylesheet and just adding it to the pages required fixes the issue with the window now appearing when called from a RadGrid.  Obviously works differently to the Scheduler.

    Dave Penny
Back to Top