Mist can't use new TFS + Git repositor

4 posts, 0 answers
  1. J.
    J. avatar
    22 posts
    Member since:
    Jan 2013

    Posted 06 Feb 2013 Link to this post

    If I use Graphite to set up my project to use a remote repository on the new TFS + Git, it works, but the same URL in Mist doesn't work ( http://blogs.msdn.com/b/bharry/archive/2012/08/13/announcing-git-integration-with-tfs.aspx)

    For example: https://accountname.visualstudio.com/defaultcollection/_git/ProjectName

    I assume this is because the URL doesn't end with ".git"
  2. Ivan K. Ivanov
    Admin
    Ivan K. Ivanov avatar
    32 posts

    Posted 07 Feb 2013 Link to this post

    Hello Jonathan,

    Unfortunately. this is a bug in Mist. The problem is the "_" in the url. We logged this issue in our bug tracking system so the fix will be available in our next release.
    In the meanwhile, you can use Graphite to set the remote repository url.

    We are sorry for the inconvenience.

     
    All the best,

    Ivan K. Ivanov
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Pluralsight.
  3. Quent
    Quent avatar
    5 posts
    Member since:
    Nov 2011

    Posted 09 Aug 2013 Link to this post

    Is Mist able to access TFS + Git now?  I'm getting challenged for a Git Login, but the Live Id credentials I provided don't work.

    (Unfortunately I can't use Graphite because it doesn't seem to work behind our firewall.)
  4. Quent
    Quent avatar
    5 posts
    Member since:
    Nov 2011

    Posted 09 Aug 2013 Link to this post

    umm ... never mind.  Just saw the post on how to set alternate credentials in TFS+GIT.
    In case others run across this post and are equally challenged at finding other posts, here's what you need to do:

    Mist apparently can't access TFS+GIT using Live Id and so needs Basic Auth set up on the TFS+GIT side.  So on the TFS+GIT side do the following:
    * On the header bar, click on your accout name, then My Profile
    * Select the Credentials tab
    * Read the warnings then select Enable Alternate Credentials
    * Provide a password to use for basic authentication (I kept the Secondary Username blank/unset)

    Now on the Mist side, after setting the remote Git repository, when you Push your updates you'll be challenged for a username and password.  Enter your Live Id email address and the alternate password you provided above.

    Works great!
Back to Top