Mist - Clone project - doesn't accept hyphens '-' in git URL

2 posts, 0 answers
  1. Oliver
    Oliver avatar
    1 posts
    Member since:
    Nov 2013

    Posted 07 Nov 2013 Link to this post

    If I use Mist and go to:

    Dashboard > Clone > Repository 

    and then in the Git URL text input, enter a URL containing a hyphen I get an error on the field that says - 'Enter a valid git project URL'

    EDIT ---

    OK so it looks like it doesn't accept hyphens EXCEPT if you are using a URL for githuib


    https://github.com/telerik/everlive-push-hybrid.git <- VALID

    Change anything in the URL part and immediately it's invalid

    https://githubb.com/telerik/everlive-push-hybrid.git <- INVALID

    And then remove the hyphens and it's valid again - weird:

    https://githubb.com/telerik/everlivepushhybrid.git <-VALID


    Removing the hyphen removes the validation error - but doesn't help me because there is actually a hyphen in the URL of the repository that I need to clone.


    With a hyphen:

    Just deleting the hyphen:


  2. Steve
    Steve avatar
    10941 posts

    Posted 07 Nov 2013 Link to this post

    Hi Oliver,

    Thanks for bringing this to our attention, it is a regression in the latest version. We would do our best to address it for the upcoming hotfix (probably next week). For the time being you can use Graphite to clone your repository and then open it and work in Mist.

    Please excuse us for the temporary inconvenience. Your Telerik points have been updated as token of gratitude for bringing this to our attention.

    You've missed the Icenium Visual Studio Integration keynote? It has been recorded and posted here.
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
Back to Top