Missing styles on Editor Dialogs...

2 posts, 0 answers
  1. Allen Smothers
    Allen Smothers avatar
    40 posts
    Member since:
    Nov 2006

    Posted 03 Mar 2010 Link to this post

    Hello,

    We have several toolbar items on our editor including the LinkManager and TableWizard.   After following the documentation and updating the DialogsCssFile for the editors via a skin file (Using Office2007 theme) we are missing the styling for the dialogs.

    I've included a screenshot of the correct styled dialog from your hosted demo:  http://i.imgur.com/t4yve.jpg
    And the missing styles from our hosted site:http://i.imgur.com/NTpZw.png

    We are using a different ToolBar theme (Default theme) in our skin file, could this be messing up our dialogs?
    If not, any idea what we're missing as far as styles go?  

    Thanks a bunch!
    Allen
  2. Dobromir
    Admin
    Dobromir avatar
    1633 posts

    Posted 04 Mar 2010 Link to this post

    Hi Allen,

    Some of the decorations are missing because assigning CSS files of a different skin for the dialogs leads to:
    1. Overriding some of the global rules.
    2. Skipping skin specific rules because the CSS inheritance structure differs from skin to skin (skin names are different).
    By design, RadEditor does not offer the possibility to register different skins for the editor and its dialogs. At present we do not plan to change this behavior.

    Best regards,
    Dobromir
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top