Missing Intellisense/Unrecognized tag prefix

4 posts, 0 answers
  1. dhuss
    dhuss avatar
    120 posts
    Member since:
    Sep 2009

    Posted 12 Dec 2013 Link to this post

    I just updated my VS2012 to update 4 and my Telerik controls to v.2013.3.114.35. I also have JustCode v2013.3.1119.1 installed. Since then, my aspx intellisense no longer works for the telerik controls and I also get an "unrecognized tag prefix or device filter 'telerik'" message on each telerik control (tag.jpg). I have my telerik controls registered in my web.config file instead of on each aspx page (there are 300+ pages). I can see the controls in design view, the project compiles and runs okay. I do get intellisense for the asp controls (aspx) and for both asp and telerik in the code behind (vb). I have uninstalled the telerik controls and reinstalled, all to no avail. I have disabled/enabled JustCode. When I am inside a telerik control (aspx) and hit the space bar (intellisense should kick in here) all I get is a ( "db" Markup snippet for a data-bind attribute ) (snippet.jpg) in place of the intellisense.

    Does anyone have any idea of how to fix this.

    <pages>
         <controls>
             <add assembly="Telerik.Web.UI" namespace="Telerik.Charting" tagPrefix="telerik" />
             <add assembly="Telerik.Web.UI" namespace="Telerik.Web.UI" tagPrefix="telerik" />
             <add assembly="AjaxControlToolkit" namespace="AjaxControlToolkit" tagPrefix="ajax" />
  2. dhuss
    dhuss avatar
    120 posts
    Member since:
    Sep 2009

    Posted 12 Dec 2013 Link to this post

    One thing I forgot to mention is this solution/project was created in vs2008 and upgraded to vs2012.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 17 Dec 2013 Link to this post

    Hello Dennis,

    This error is showed by VS and not by JustCode that is why nothing is improved when JustCode is disabled.
    I made some research and found the following articles that could help:
    1. Link1
    2. Link2
    Unfortunately, I was unable to reproduce the issue and test the solutions. 
    Thanks.

    Regards,
    Zdravko
    Telerik
    Share what you think about JustCode with us, so we can help you even better! You can use the built-in feedback tool inside JustCode, our forum, or our JustCode feedback portal.
  5. dhuss
    dhuss avatar
    120 posts
    Member since:
    Sep 2009

    Posted 17 Dec 2013 Link to this post

    I found several posts across the internet with users having the same problem. One post showed changes that were made to the web.config file, so I made the following change to the web config file and all intellisense works. Not sure why it works but it does.

    Old settings in the configuration/configsections
    <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
        <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
            <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false"/>
            <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
                <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere"/>
                <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false"/>
                <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false"/>
                <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false"/>
            </sectionGroup>
        </sectionGroup>
    </sectionGroup>

    Changes:
    <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
        <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
        <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
        <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
            <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere" />
            <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
            <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
            <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
        </sectionGroup>
        </sectionGroup>
    </sectionGroup>

Back to Top