Missing feature?

11 posts, 0 answers
  1. Eric Schoenholzer
    Eric Schoenholzer avatar
    138 posts
    Member since:
    Mar 2004

    Posted 11 May 2011 Link to this post

    I would like to disable JustTrace for all projects.
    But it seems that JustTrace asks for each project, how to run ("Start profiling" Dialog). 

    So, this would be a feature request.

    Thanks
    Eric
  2. Dwight
    Admin
    Dwight avatar
    475 posts

    Posted 12 May 2011 Link to this post

    Hi Eric,

    Thanks for writing. I'm not sure that I fully understand the specifics of your request. Can you, please, provide more information, and probably some scenarios / use cases that will help us better understand your request?

    Best,
    Dwight
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

  3. DevCraft banner
  4. Eric Schoenholzer
    Eric Schoenholzer avatar
    138 posts
    Member since:
    Mar 2004

    Posted 17 May 2011 Link to this post

    Hi,

    Easy steps to reproduce it:

    - Install JT
    - Create a project (Web / Winform / etc.)
    - Run Project
    - "Start profiling" dialog pops up (see attachment)


    This happens each time when I create or open a project.

    To avoid the dialog, I would like to have a global option to disable/enable JT (and with that the 'start profiling'-dialog).

    Thanks
    Eric


  5. Vladi
    Admin
    Vladi avatar
    167 posts

    Posted 30 May 2011 Link to this post

    Hi Eric,

     
    The issue you have reported should be fixed now. Please try our new Beta version and let us know if you still similar troubles. Any other feedback is also welcome.

    All the best,
    Vladi
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

  6. Eric Schoenholzer
    Eric Schoenholzer avatar
    138 posts
    Member since:
    Mar 2004

    Posted 03 Jun 2011 Link to this post

    Hi,

    Not sure if I have made my wishes clear.
    But it seems that the behavior is still the same.

    I would like to disable JT globally, not only during a VS session.
    When I close VS and open it again, JT is enabled again.


    Thanks
    Eric
  7. Vladi
    Admin
    Vladi avatar
    167 posts

    Posted 06 Jun 2011 Link to this post

    Hi Eric Schoenholzer,

    Thanks for the follow-up. You can disable JT globally from the Add-in Manager of Visual Studio which is located in Tools->Add-in Manager. Be sure to uncheck the checkbox in front of Telerik JustTrace. Please try and let me know if it works for you.

    All the best,
    Vladi
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

  8. Eric Schoenholzer
    Eric Schoenholzer avatar
    138 posts
    Member since:
    Mar 2004

    Posted 06 Jun 2011 Link to this post

    Thanks Vladi,

    Disabling the entire addin? Perhaps I need to restart VS too?

    No, I would prefer to have the feature like in JustMock.
    There you have an option to disable it and reenable it again without restarting.

    Thanks
    Eric
  9. Vladi
    Admin
    Vladi avatar
    167 posts

    Posted 07 Jun 2011 Link to this post

    Hello Eric Schoenholzer,

    Thank you again for following up. Actually you don't need to restart the Visual Studio. If you disable JustTrace from the Add-in Manager, it will be disabled in real time and no restart is needed. Please try it and let me know if it works for you as I may be wrong.

    Kind regards,
    Vladi
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

  10. Eric Schoenholzer
    Eric Schoenholzer avatar
    138 posts
    Member since:
    Mar 2004

    Posted 08 Jun 2011 Link to this post

    Hi,

    When I disable the AddIn, it has more or less the same behavior like the "Disabling JT"-Option during a VS session.
    Because the AddIn has the 'Startup'-Flag, it get's started again.

    Why not making the "Disable JustTrace" option durable/sticky over VS sessions? (same behavior like "Disable JustMock").

    Thanks
    Eric

  11. Mihail
    Admin
    Mihail avatar
    75 posts

    Posted 08 Jun 2011 Link to this post

    Hello Eric,

    Thank you for your feedback. We will provide a fix for the official release. Until then I would suggest to uncheck both "Available Add-ins" and "Start" options from Add-in Manager menu. When you want to try JustTrace check "Available Add-ins" option only. Sorry for the inconvenience.

    Kind regards,
    Mike
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

  12. Eric Schoenholzer
    Eric Schoenholzer avatar
    138 posts
    Member since:
    Mar 2004

    Posted 08 Jun 2011 Link to this post

    Thanks for the response.

    Thanks, I will wait for the next release.
    I'm not working as Admin, so I'm not able to disable the "Start" option easily.

    Eric
Back to Top
DevCraft banner