Menus that have children are not displaying on IE10

5 posts, 0 answers
  1. Tom
    Tom avatar
    12 posts
    Member since:
    May 2013

    Posted 08 Jul 2013 Link to this post

    We recently purchased the Kendo MVC wrappers.  Now an MVC4 app that uses the Kendo menus and worked with the trial license, doesn't display any of the menus that have sub-menus until you either resize the window or mouse over the menu.  Menu items that have no children display when the page initially renders.  We see this only in IE 10.  Firefox, Chrome, & Safari all show-up as expected.
  2. Dimiter Madjarov
    Admin
    Dimiter Madjarov avatar
    2159 posts

    Posted 10 Jul 2013 Link to this post

    Hello Tom,


    We are unaware of such issue in Internet Explorer 10 and I was unable to reproduce it on my side or in the Demos. Could you please send me a sample project, where the problem is reproducing, so I could inspect it locally, pinpoint the exact reason and assist you further?

    Thanks in advance for your cooperation. I am looking forward to hearing from you.

     

    Regards,
    Dimiter Madjarov
    Telerik
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  3. Kendo UI is VS 2017 Ready
  4. Tom
    Tom avatar
    12 posts
    Member since:
    May 2013

    Posted 10 Jul 2013 Link to this post

    Thanks Dimiter!

    Are there any known issues hosting a menu in something like this?
    @{Html.RenderAction( "TopMenu", "Navigation" );}
    If I pull the menu out and place it directly in my _Layout.cshtml it works as it should.
  5. Dimiter Madjarov
    Admin
    Dimiter Madjarov avatar
    2159 posts

    Posted 12 Jul 2013 Link to this post

    Hello Tom,


    No, placing the menu in another view and invoking it with RenderAction should not be the reason for the issue. It is rendering the menu as expected on my side.

    Please let me know if I could assist you further.


    Regards,
    Dimiter Madjarov
    Telerik
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  6. Tom
    Tom avatar
    12 posts
    Member since:
    May 2013

    Posted 12 Jul 2013 Link to this post

    I got it to work.  There was an issue in the style sheet.  Changed to a different skin and it's working.

    Thank you for your help
Back to Top
Kendo UI is VS 2017 Ready