Menu animation bug

4 posts, 0 answers
  1. Sergey
    Sergey avatar
    3 posts
    Member since:
    Jul 2010

    Posted 23 Sep 2011 Link to this post

    Hi

    RadMenu has animation bug. When mouse move throw top level menu line, the dropdown menu first appear, than disaper and then animated scrolldown. There are some blicking effect.

    And now we are turn off animation.

    <Window x:Class="MenuSample.MainWindow"
            Title="MainWindow" Height="350" Width="525">
        <Grid>
            <telerik:RadMenu VerticalAlignment="Top" x:Name="mainMenu">
                <telerik:RadMenuItem Header="File">
                    <telerik:RadMenuItem Header="Menu1"/>
                    <telerik:RadMenuItem Header="Menu2"/>
                    <telerik:RadMenuItem Header="Menu3"/>
                </telerik:RadMenuItem>
                <telerik:RadMenuItem Header="View">
                    <telerik:RadMenuItem Header="Menu1"/>
                    <telerik:RadMenuItem Header="Menu2"/>
                    <telerik:RadMenuItem Header="Menu3"/>
                </telerik:RadMenuItem>
                <telerik:RadMenuItem Header="Help">
                    <telerik:RadMenuItem Header="Menu1"/>
                </telerik:RadMenuItem>
                <telerik:RadMenuItem Header="Help2">
                    <telerik:RadMenuItem Header="Menu1"/>
                    <telerik:RadMenuItem Header="Menu2"/>
                </telerik:RadMenuItem>
                <telerik:RadMenuItem Header="Help3">
                    <telerik:RadMenuItem Header="Menu1"/>
                    <telerik:RadMenuItem Header="Menu2"/>
                    <telerik:RadMenuItem Header="Menu3"/>
                </telerik:RadMenuItem>
            </telerik:RadMenu>
        </Grid>
    </Window>



  2. Pana
    Admin
    Pana avatar
    748 posts

    Posted 28 Sep 2011 Link to this post

    Hello Sergey,

    You can remove the animations like this:
    <Window x:Class="WpfApplication1.MainWindow"
            xmlns:animation="clr-namespace:Telerik.Windows.Controls.Animation;assembly=Telerik.Windows.Controls"
            Title="MainWindow" Height="350" Width="525">
        <Grid>
            <telerik:RadMenu VerticalAlignment="Top" x:Name="mainMenu" animation:AnimationManager.AnimationSelector="{x:Null}">
                <telerik:RadMenuItem Header="File">
                    <telerik:RadMenuItem Header="Menu1"/>
                    <telerik:RadMenuItem Header="Menu2"/>
                    <telerik:RadMenuItem Header="Menu3"/>
                </telerik:RadMenuItem>
                <telerik:RadMenuItem Header="View">
                    <telerik:RadMenuItem Header="Menu1"/>
                    <telerik:RadMenuItem Header="Menu2"/>
                    <telerik:RadMenuItem Header="Menu3"/>
                </telerik:RadMenuItem>
                <telerik:RadMenuItem Header="Help">
                    <telerik:RadMenuItem Header="Menu1"/>
                </telerik:RadMenuItem>
                <telerik:RadMenuItem Header="Help2">
                    <telerik:RadMenuItem Header="Menu1"/>
                    <telerik:RadMenuItem Header="Menu2"/>
                </telerik:RadMenuItem>
                <telerik:RadMenuItem Header="Help3">
                    <telerik:RadMenuItem Header="Menu1"/>
                    <telerik:RadMenuItem Header="Menu2"/>
                    <telerik:RadMenuItem Header="Menu3"/>
                </telerik:RadMenuItem>
            </telerik:RadMenu>
        </Grid>
    </Window>


    Best wishes,
    Pana
    the Telerik team
    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>
  3. UI for WPF is Visual Studio 2017 Ready
  4. Charles
    Charles avatar
    41 posts
    Member since:
    Mar 2012

    Posted 29 Jul 2012 Link to this post

    Rather than disabling animation, is there any way to fix or workaround this bug?

    The menu loads with all items enabled, and then closes, and then re-opens with enabled state as expected due to command bindings.

    I've had to disable animation for now, but would rather not.
  5. Rosen Vladimirov
    Admin
    Rosen Vladimirov avatar
    640 posts

    Posted 31 Jul 2012 Link to this post

    Hi,

    Can you give us more information how to reproduce the issue:
    - Is it WPF or Silverlight application?
    - How many menu items do you have?
    - Which version of  RadControls are you using? Can you reproduce the problem with our latest release?
    - How do you set the command bindings?

    This information is needed to provide quality and on time help. Please share the details and if possible a sample project.

    Thanks in advance for your help and understanding!

    Regards,
    Rosen Vladimirov
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

Back to Top