Media Player in a Repeater Control

3 posts, 0 answers
  1. Samarth Nagaraj
    Samarth Nagaraj avatar
    2 posts
    Member since:
    Mar 2010

    Posted 06 Mar 2010 Link to this post

    Hello Telerik Team,

    We have a requirement of displaying video files within a radrotator in a repeater control. I have been able to display the videos from respective video libraries, however, when i click the default next button of the radrotator to see the next set of videos i get a javascript error and all the videos stop playing & gets a distorted look.

    The effect is the same when i set the radrotatortype to "Automatic Advance". Earlier, i tried displaying images and it worked fine. But the videos are giving a problem. Can you help? Also, wanted to know if it is a bug or am i doing something wrong?
  2. Samarth Nagaraj
    Samarth Nagaraj avatar
    2 posts
    Member since:
    Mar 2010

    Posted 09 Mar 2010 Link to this post

    Can somebody help me out please?
  3. DevCraft banner
  4. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 11 Mar 2010 Link to this post

    Hello Samarth,

    I suggest to use the videoplayer' (that you are using) API and to explicitly stop and play videos whenever they been hidden / shown. If you still experience problems after that, please open a support ticket and send us a sample project that reproduces your setup so we could check it.


    Greetings,
    Georgi Tunev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Back to Top