MaskedEdit Percentage Behaviour

3 posts, 0 answers
  1. Muhammad Khalid
    Muhammad Khalid avatar
    9 posts
    Member since:
    Jul 2008

    Posted 05 Nov 2009 Link to this post

    HI Telerik,
                     This s inform to you that i have using MaskedEdit Textbox as percentage mask fix .
     The 1st problem is that with MaskEdit box deafult value look like is "0.00 %"  another my requirements is "0%" how can i use/set mask look like "0%"

    and other problem with this if the cursor are stand start of text on left side  value e.g "cursor Position is here  0%"  if i press the backspace button why the value are deleted on right side can you please help me to do fixing issue/problem.

    percentage should in numeric value , cannot used as floating point that is big issue with MaskPercentage .

    thanks
    Khalid
  2. Robert
    Robert avatar
    82 posts
    Member since:
    Jun 2009

    Posted 09 Nov 2009 Link to this post

    Hello Khalid,

    You can specify the amount of decimal places in a numeric mask by typing a precision number after the mask. This number specifies the amount of decimal places you would like to use.

    For example (Numeric mask):
    p3 would show up as 0.000 %
    p0 would show up as 0 %

    - Robert
  3. UI for WinForms is Visual Studio 2017 Ready
  4. Muhammad Khalid
    Muhammad Khalid avatar
    9 posts
    Member since:
    Jul 2008

    Posted 09 Nov 2009 Link to this post

    Hello Robert,
             Thanks for replying, This Issue i had already fixed , Can you please tell me the solution of second issue , i was post on my last message, That is Back Space behavior is not understandable,


    and other problem with this if the cursor are stand start of text on left side  value e.g "cursor Position is here  0%"  if i press the backspace button why the value are deleted on right side can you please help me to do fixing issue/problem.

    for example if the value is    123456789%       

    if my cursor are stand on 9th character if i press the back space button, 9 word are deleted but the cursor position are not focus on 8th words while cursor position are move to before 7th word, how can i fix this issue . 
     
Back to Top