Mapping iOS Simulator

4 posts, 0 answers
  1. Greg Duffield
    Greg Duffield avatar
    38 posts
    Member since:
    Feb 2006

    Posted 20 Nov 2012 Link to this post

    When running the sample Coffee House Application if you scroll/pan the map this does not fetch any new tiles or draw any new bits of the map, it only leaves a Grey border.

    I can replicate this with both Google Maps and Bing Maps both doing the same thing, can you please let me know how I can get the map to fetch the new data when the view is changing?

    However everything works as it should using he Android Simulator, I have noticed that this maybe something to do with device/browser detection as in the iOS simulator the google map still shows the Scale buttons (plus and minus) which should not be there as this is controlled using pinch and zoom if detected correctly.
  2. Jordan
    Admin
    Jordan avatar
    197 posts

    Posted 20 Nov 2012 Link to this post

    Hello Greg,

    Thank you for reporting this, we were able to reproduce and pinpoint the issue and log for investigation and bug fixing.

    You can workaround it via debugger settings (look at gear icon at bottom right corner) and check [Emulate touch events] option.

    All the best,

    Jordan
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Pluralsight.
  3. Greg Duffield
    Greg Duffield avatar
    38 posts
    Member since:
    Feb 2006

    Posted 23 Nov 2012 Link to this post

    This also happens when using ION on the iPhone though so you end up with the map not being usable, as soon as you drag it too look elsewhere you are left with just a grey area.
  4. Deyan Varchev
    Admin
    Deyan Varchev avatar
    150 posts

    Posted 26 Nov 2012 Link to this post

    Hi,

     I have tested the Jitterz Coffeehouse app on a variety of devices (both iOS and Android) - inside Ion as well. In all tests the map loads fine after dragging away from the default place. 
    The problem that you describe could be some temporary google maps issue. Can you try that again?
    You can also try and reinstall Ion and redeploy the app. 

    If this does not help, please write us back with some more details on the device and OS version that you are testing on - iPhone 4/4S/5, iOS version. 

    Regards,
    Deyan Varchev
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Pluralsight.
Back to Top