Make app available for tablets in Google Play

7 posts, 0 answers
  1. Jan-Dirk
    Jan-Dirk avatar
    327 posts
    Member since:
    Jun 2012

    Posted 12 Jul 2013 Link to this post

    I would like to make my app available for tablets. Since I am using Kendo UI this should be easy to do. I added a 7" and 10" screen in the store listing, but I still get two errors from Google Play:

    1. Uses available screen space on tablets Learn more
    2. Target and minimum Android versions support tablets (check targetSdkVersion and minSdkVersion Learn more

    Issue no. 2 is quite easy to solve by adding 'android:targetSdkVersion="11"' and changing 'android:minSdkVersion="8"' to 'android:minSdkVersion="11"' in AndroidManifest.xml.

    However, I haven't been able to find any valuable information what to do to solve issue no. 1. Any hints on this?

  2. David Silveria
    David Silveria avatar
    234 posts
    Member since:
    May 2006

    Posted 13 Jul 2013 Link to this post

    http://developer.android.com/distribute/googleplay/quality/tablet.html#support-screens

    Did you add this to AndroidManifest?
  3. Jan-Dirk
    Jan-Dirk avatar
    327 posts
    Member since:
    Jun 2012

    Posted 15 Jul 2013 Link to this post

    Yes, they are there by default:

    <supports-screens
                    android:largeScreens="true"
                    android:normalScreens="true"
                    android:smallScreens="true"
                    android:xlargeScreens="true"
                    android:resizeable="true"
                    android:anyDensity="true"
    />
  4. Jan-Dirk
    Jan-Dirk avatar
    327 posts
    Member since:
    Jun 2012

    Posted 15 Jul 2013 Link to this post

    These settings are there already by default
  5. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 15 Jul 2013 Link to this post

    Hello JD,

    By default, the Android permissions in the Icenium properties include RECEIVE_SMS which implies that the device is a mobile phone. You would need to remove this permission, rebuild your app and publish new version in Google Play.

    We would consider removing this permission from the default ones.

    Regards,
    Steve
    Telerik

    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Missed our first webinar, watch it here.
    Share feedback and vote for features on our Feedback Portal.
  6. Jan-Dirk
    Jan-Dirk avatar
    327 posts
    Member since:
    Jun 2012

    Posted 15 Jul 2013 Link to this post

    Hello Steve,

    My App does not have the RECIEVE_SMS property. I removed that when before I first published the app.
  7. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 16 Jul 2013 Link to this post

    Hello JD,

    Try without the "android.permission.READ_PHONE_STATE" and see how it goes.

    Regards,
    Steve
    Telerik

    Do you enjoy Icenium? Vote for it as your favorite new product here (use short code H048S).
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
Back to Top