Major problem with textboxes in RadWindow on WinRT

14 posts, 1 answers
  1. Andreas
    Andreas avatar
    137 posts
    Member since:
    May 2008

    Posted 09 Jan 2013 Link to this post

    Hi,

    We have an Asus WinRT device...
    When using IE10 on this device in Metro Mode, and "tapping" on a textbox that is located inside a RadWindow, the soft keyboard appears, but ½ a second later, the textbox loses focus and the keyboard disappears. This makes it impossible to write anything in the textbox!

    The same behavior can be seen on your demo:
    http://demos.telerik.com/aspnet-ajax/window/examples/overview/defaultcs.aspx
    When setting focus on the Bing search text-field, it loses focus when tapping.

    Regards
    Caesar
  2. Marin Bratanov
    Admin
    Marin Bratanov avatar
    3599 posts

    Posted 11 Jan 2013 Link to this post

    Hello Caesar,

    Can you confirm this behavior does not manifest with simple inputs that are absolutely positioned on the page so that they are in the area where the keyboard will appear? Or with an absolutely positioned iframe that hosts the page with inputs? This is the only case when we were able to see this behavior and it seems that the device gets confused by its own actions - it first scrolls the page so the input is visible above the keyboard then seems to think it has lost focus. Could you test on your end to see if this is also the scenario you have so we can confirm the actual use case and circumstances with this behavior?


    Regards,
    Marin Bratanov
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Andreas
    Andreas avatar
    137 posts
    Member since:
    May 2008

    Posted 15 Jan 2013 Link to this post

    Hi,

    In your demo (http://demos.telerik.com/aspnet-ajax/window/examples/overview/defaultcs.aspx), it is the same behavior if the input is located where the keyboard will appear or not. When I test i portrait mode, the page doesn't need to scroll but it still loses focus...

    /Caesar
  5. Answer
    Marin Bratanov
    Admin
    Marin Bratanov avatar
    3599 posts

    Posted 16 Jan 2013 Link to this post

    Hello Caesar,

    We have been investigating this case and we have tracked the origin of this behavior to the RestrictionZoneID property. If a restriction zone is used this behavior is observed. So far the possible workaround is to avoid using this feature. I have also logged this issue here and I have updated your Telerik points for helping us find it.


    Greetings,
    Marin Bratanov
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  6. Korn1699
    Korn1699 avatar
    33 posts
    Member since:
    Apr 2007

    Posted 29 May 2013 Link to this post

    Marin,

    Is there any update on a solution that doesn't involve not using the RestrictedZoneID?  It looks like it is still an issue, and this thread is over 4 months old now, so I though I would ask.  We use that property in a lot of places, and it would really be nice if people could use a Windows 8 tablet on our site without needing a physical keyboard.  This issue doesn't occur on the desktop browser, BUT the virtual keyboard covers about half the screen.  It doesn't adjust the screen to keep the textbox visible, as the metro browser does.

    Mike Dennis
  7. Marin Bratanov
    Admin
    Marin Bratanov avatar
    3599 posts

    Posted 30 May 2013 Link to this post

    Hi Mike,

    I am afraid this issue is not fixed yet, we have been focusing on important tasks like creating the RadTileList control. You can use the feedback portal to comment, and track the problem, voting for it can raise its priority.

    Another thing you can try is using an entire page in the RadWindow, instead of the ContentTemplate. This demo can show you how to return data from it to the main page.


    Regards,
    Marin Bratanov
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  8. Korn1699
    Korn1699 avatar
    33 posts
    Member since:
    Apr 2007

    Posted 30 May 2013 Link to this post

    Marin,

    Ok, I am looking forward to that control.  I guess it just seemed to me that a major control not working on Windows 8 touch devices, would be considered a major issue...  Maybe people just use it less than we do...  Most of our internal apps make heavy use of the RadWindow, so they are basically useless now on Windows tablets, unless the user has a keyboard with it. 

    We generally do use other full pages in the RadWindows, but I am still seeing it with that too...

    Mike Dennis
  9. Dobromir
    Admin
    Dobromir avatar
    1633 posts

    Posted 04 Jun 2013 Link to this post

    Hi Mike,

    Thank you for your feedback.

    I will contact the developers team in order to increase this issues priority. Unfortunately, I am not able to provide any firm estimate for a fix. Please excuse us for the inconvenience.

    Regards,
    Dobromir
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  10. Thierry
    Thierry avatar
    14 posts
    Member since:
    Feb 2011

    Posted 29 Jul 2014 Link to this post

    Hi Dobromir,

    What is the status on this issue? We are facing the exact same problem here and it is a critical problem for us as we are pushing a lot of Windows 8 devices in our organization.

    Regards
    Thierry
  11. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 29 Jul 2014 Link to this post

    Hello Thierry,

    I raised the priority of this issue in our bug tracking system to critical. We will try to fix it for the Q3 2014 release.

    Best regards,
    Rumen
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  12. Thierry
    Thierry avatar
    14 posts
    Member since:
    Feb 2011

    Posted 29 Jul 2014 in reply to Rumen Link to this post

    Thank you Rumen. Looking forward to the Q3 release then.

    Regards
    Thierry
  13. Thierry
    Thierry avatar
    14 posts
    Member since:
    Feb 2011

    Posted 29 Oct 2014 in reply to Rumen Link to this post

    Hi Rumen,

    Was this issue fixed in the Q3?

    Thierry
  14. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 29 Oct 2014 Link to this post

    Hi Thierry,

    The issue is still not fixed, but it's planned for fixing in our next sprint. If we managed to resolve it, the fix will appear in the Q3 2014 SP1 release.

    The Service Pack date is under TBD, but it is usually launched a month after the official release.

    Kind regards,
    Rumen
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  15. Thierry
    Thierry avatar
    14 posts
    Member since:
    Feb 2011

    Posted 29 Oct 2014 in reply to Rumen Link to this post

    Thanks for the quick reply Rumen. That will be really helpful for us so i hope it makes the cut.

    Right now, our app simply can't be used on the Windows 8 browser due to this.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017