Long Running Script Error in RadEditor

2 posts, 0 answers
  1. Tonya
    Tonya avatar
    12 posts
    Member since:
    Mar 2008

    Posted 17 Mar 2015 Link to this post

    When a certain combination of html is pasted into a RadEditor on our site, the webpage freezes and eventually we get the Long Running Script error.

    The text I am test is nothing too strange:

    For registration information Alicia Pierre Louis at <a href="mailto:asearles@misd.net">asearles@misd.net</a>.&nbsp; Join us for one more day of professional learning experience of bringing the Common Core Reading Standards to your K-2 classroom.&nbsp; We will take a look at the "brand new" MAISA Reading Units K-2. We will also include a half day session of leveled texts.

    If I shorten it to the following, I don't get the error:

    at <a href="mailto:asearles@misd.net">asearles@misd.net</a>.&nbsp; Join us for one more day of professional learning experience of bringing the Common Core Reading Standards to your K-2 classroom.&nbsp; We will take a look at the "brand new" MAISA Reading 

    If I don't have both a mailto link and the double quotes, I don't get the error.

    I was able to reproduce the problem in some sample code I found at http://www.telerik.com/forums/paste-plain-text-pop-up-causes-you-to-jump-to-the-top-of-the-page.

    I'm using version 2014.3.1024.35.



  2. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 20 Mar 2015 Link to this post

    Hi Tonya,

    The matter described here has been discussed in a ticket thread.

    For anyone else interested on the matter, the issues has been fixed by upgrading to 2015 Q1 version.

    Regards,
    Ianko
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top