<location path="Telerik.Web.UI.WebResource.axd">

6 posts, 0 answers
  1. Frank
    Frank avatar
    86 posts
    Member since:
    Mar 2012

    Posted 06 Jun 2014 Link to this post

     I have a web page that appears to work but on the login page the radbutton does not display correctly.

      <location path="Telerik.Web.UI.WebResource.axd">
          <system.web>
              <authorization>
                  <allow users="*"/>
              </authorization>
          </system.web>
      </location>
    <system.web>
          <authorization>
              <deny users="?"/>
          </authorization>
      </system.web>

    When I run the app from visual studio I get the error
    JavaScript critical error at line 2, column 1 in http://localhost:49582/Account/Login\n\nSCRIPT1002: Syntax error

    The issue seems to be with the WebResources intellisenece says there is no resource at the location.  Is there a new location I should be pointing to?
    Or do I need to implicitly deny  resources rather than a blanket deny and the implicit allows?


  2. Plamen
    Admin
    Plamen avatar
    2731 posts

    Posted 11 Jun 2014 Link to this post

    Hi Frank,

    It looks like the global setting is overriding the setting in the location tag. You can try to set the allowOverride property of location tag  to false.

    Hope this will help you solve the issue.

    Regards,
    Plamen
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Frank
    Frank avatar
    86 posts
    Member since:
    Mar 2012

    Posted 11 Jun 2014 in reply to Plamen Link to this post

    I tried that but I still get the same error.  The odd thing is this only is an issue with ie11 that I know of.  I have tested with Firefox, Chrome, and Safari and they all work fine. 
  5. Plamen
    Admin
    Plamen avatar
    2731 posts

    Posted 16 Jun 2014 Link to this post

    Hi Frank,

    The issue is quite unusual indeed. Would you please try to remove all the location setting for the user than the one for Telerik.Web.UI.WebResource.axd and test if it is working correctly?

    You can also check the troubleshooting in this help topic in case some of the issues is solving your issue too.

    Since the issue seems to be connected with some custom settings it could be useful if you try to isolate it in a sample page and submit a support ticket where we could inspect it and be more helpful.

    Regards,
    Plamen
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  6. Frank
    Frank avatar
    86 posts
    Member since:
    Mar 2012

    Posted 09 Jul 2014 in reply to Plamen Link to this post

    No this has done nothing to help.
  7. Plamen
    Admin
    Plamen avatar
    2731 posts

    Posted 11 Jul 2014 Link to this post

    Hi,

    Since nothing of the suggestions helped I would recommend you to isolate the issue in a sample page and submit a support ticket where we could inspect it and be more helpful.

    Regards,
    Plamen
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017