loadingpanel not working

4 posts, 0 answers
  1. Fit2Page
    Fit2Page avatar
    371 posts
    Member since:
    Feb 2007

    Posted 15 Jun 2016 Link to this post

    In the following masterpage setup AJAX is working correctly but the LoadingPanel is not showing:

    <telerik:RadAjaxLoadingPanel ID="RadAjaxLoadingPanel1" Skin="Default" runat="server" />

    <telerik:RadAjaxManager EnableAJAX="true" ID="RadAjaxManager1" runat="server">
        <AjaxSettings>
            <telerik:AjaxSetting AjaxControlID="RecordOverview">
                <UpdatedControls>
               <telerik:AjaxUpdatedControl ControlID="RecordOverview" LoadingPanelID="RadAjaxLoadingPanel1"></telerik:AjaxUpdatedControl>
                </UpdatedControls>
            </telerik:AjaxSetting>
        </AjaxSettings>
    </telerik:RadAjaxManager>

    <asp:contentplaceholder id="RecordOverview" runat="server"></asp:contentplaceholder>

     

    Any clue?

     

    Marc

  2. Maria Ilieva
    Admin
    Maria Ilieva avatar
    4017 posts

    Posted 16 Jun 2016 Link to this post

    Hi,

    Please add an asp panel that wraps the content in the RecordOverview PlaceHolder and use this asp Panel in the Ajax settings and see how it goes.

    Regards,
    Maria Ilieva
    Telerik
    Do you need help with upgrading your ASP.NET AJAX, WPF or WinForms projects? Check the Telerik API Analyzer and share your thoughts.
  3. Fit2Page
    Fit2Page avatar
    371 posts
    Member since:
    Feb 2007

    Posted 17 Jun 2016 in reply to Maria Ilieva Link to this post

    Good catch Maria, thank you
  4. Maria Ilieva
    Admin
    Maria Ilieva avatar
    4017 posts

    Posted 17 Jun 2016 Link to this post

    Hello,

    I'm glad that the provided solution helped. Do not hesitate to contact us back in case furtehr assistance is needed.

    Regards,
    Maria Ilieva
    Telerik
    Do you need help with upgrading your ASP.NET AJAX, WPF or WinForms projects? Check the Telerik API Analyzer and share your thoughts.
Back to Top