Load diagram on startup

2 posts, 1 answers
  1. ITA
    ITA avatar
    383 posts
    Member since:
    Aug 2009

    Posted 06 Jun 2014 Link to this post

    Hi,

    we start our application out of a business-software. One parameter is the path to an existing diagram, so we
    can open the application and load the diagram out of the xml-file. So far so good.

    But if we do so, the void Diagram_ShapeDeserialized will not fired. The result is the wright diagram, but without
    any custom propertie :-(

    How can we solve this problem?

    Thanks a lot
    Best Regards
    Rene
  2. Answer
    Milena
    Admin
    Milena avatar
    204 posts

    Posted 10 Jun 2014 Link to this post

    Hello Rene,

    Thank you for contacting us on that matter. Unfortunately, given only the provided information I am not able to track-down the cause of the problem. I'm sending you the project I used to reproduce the issue - with custom shapes and logic for loading a diagram from xml file. On my side the ShapeDeserialized event is fired and the diagram deserialization works as expected. 

    However, I can miss some important part of you implementation. So, please can you elaborate further on that matter and modify the attached sample to reproduce the described by you behavior. This will allow us to examine the issue locally. We can then modify the solution to work per your requirements and send it back to you.

    Thank you for your cooperation.

    Regards,
    Milena
    Telerik
     
    Check out Telerik Analytics, the service which allows developers to discover app usage patterns, analyze user data, log exceptions, solve problems and profile application performance at run time. Watch the videos and start improving your app based on facts, not hunches.
     
  3. UI for WPF is Visual Studio 2017 Ready
Back to Top