LiveSync Not Persistent

6 posts, 0 answers
  1. Thilak
    Thilak avatar
    1 posts
    Member since:
    Jun 2012

    Posted 08 May 2014 Link to this post

    I noticed that if I kill my app (iOS), and restart, LiveSync changes are lost and I need to do a three-finger refresh again. 

    A complete rebuild is required each time. I was wondering if it's a bug with Live Sync? 
  2. Iva Koevska
    Admin
    Iva Koevska avatar
    286 posts

    Posted 09 May 2014 Link to this post

    Hi Thilak,

    Thank you for sharing your experience.

    Unfortunately, at the moment, you are hitting a known issue with iOS and the three-finger LiveSync. Upon application restart, changes are lost. To retrieve them, you need to do a three-finger refresh again on application start. Subsequent three-finger refresh gestures while the app is running should be getting your changes.

    As for the complete rebuild, would you, please, be more specific? Does the three-finger refresh gesture not retrieve your changes? Which AppBuilder client are you using to develop your app? Is LiveSync enabled for the app?

    Thank you!

    Regards,
    Iva Koevska
    Telerik
     

    Share what you think about AppBuilder and Telerik Platform with us in our feedback portal, so we can become even better!

     
  3. Nader
    Nader avatar
    43 posts
    Member since:
    Jun 2013

    Posted 11 May 2014 Link to this post

    Hi Iva,
    I am also facing the same problem where I lose all of my changes when starting the app. I always have to refresh the application to get the latest updates.
    As for the complete build, when building the app using "Build" or "Build And Deploy", this newly built version becomes the base version which LiveSync reverts to later. Another thing is that when doing a three finger refresh, the app stops syncing with AppBuilder over usb as it would normally do untill I rebuild my app again.
    I am using the windows client of AppBuilder and have LiveSync enabled for the app.
  4. Iva Koevska
    Admin
    Iva Koevska avatar
    286 posts

    Posted 12 May 2014 Link to this post

    Hello Nader,

    Thanks for your report. Unfortunately, what you are hitting is a known regression that we are working on fixing in a future release. We are deeply sorry for the inconvenience and as a temporary workaround, we recommend to sticking either to LiveSync via cable (on Save) or to the three-finger gesture to avoid the second reported scenario.

    Thank you for your patience and understanding. Keep and eye out for our release notes to check whether these LiveSync issues have been resolved.

    Regards,
    Iva Koevska
    Telerik
     

    Share what you think about AppBuilder and Telerik Platform with us in our feedback portal, so we can become even better!

     
  5. Michael
    Michael avatar
    151 posts
    Member since:
    Jan 2012

    Posted 13 May 2014 in reply to Iva Koevska Link to this post

    As of today (on whatever the newest appbuilder release is), I can no longer use livesync at all on iOS. Build and deploy has also lost any apparent function. It just loads an old version of my app.
  6. Michael
    Michael avatar
    151 posts
    Member since:
    Jan 2012

    Posted 13 May 2014 in reply to Michael Link to this post

    looks better now. had to restart appbuilder a few times and now its good.
Back to Top