LiveSync doesn't work; Must delete deployed app every time

4 posts, 0 answers
  1. J.
    J. avatar
    22 posts
    Member since:
    Jan 2013

    Posted 05 Jun 2013 Link to this post

    Project LiveSync seems to be broken for me. I click on the on/off switch and nothing happens even though it says I can turn it on.

    Also, when I "Run on Device" nothing happens until I delete the previously deployed version, then it works.

    Please advise.

    Thanks,

    J. Tower
    Falafel Software
  2. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 06 Jun 2013 Link to this post

    Hello J. Tower,

    Right-click the first node in the Project Navigator and choose Build Settings and make sure that "Active Build Configuration" is either blank or "Debug". The "Release" build configuration strips out all Icenium-specific bits from your app's binary, so that might be a reason why LiveSync is not working for you.

    If that does not help try the following:
    1. Export your project as .zip archive from the DashBoard -> the icon that looks like right turn sign.
    2. Create new project and add your exported project to it (Add -> From Archive).
    3. Connect your device and deploy your app.

    You can also use the force sync work when pressing the menu button (Android) or three fingers tap (iOS) and see if that works for you.

    If the problem persists, please share what is your device, its OS version and what Cordova version does your app target?

    Regards,
    Steve
    Telerik

    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  3. J.
    J. avatar
    22 posts
    Member since:
    Jan 2013

    Posted 06 Jun 2013 Link to this post

    Thanks, Steve. The build configuration was set to "Release" accidentally.  Project LiveSync worked once I changed the build configuration back to "Debug", deleted the app from my phone manually, and re-deployed it using "Run on Device"

    Is there a feature suggestion for a better error message in this situation yet?

    J. 
  4. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 07 Jun 2013 Link to this post

    Hi J,

    This is not an error scenario, rather this behavior is by design. We have added an article to our troubleshooting documentation that covers such problem: Clicking Save in Graphite No Longer LiveSyncs Changes.

    Regards,
    Steve
    Telerik

    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Missed our first webinar, watch it here.
    Share feedback and vote for features on our Feedback Portal.
Back to Top