List View in Backstage scrolls entire backstage view

3 posts, 1 answers
  1. Michael
    Michael avatar
    19 posts
    Member since:
    Aug 2014

    Posted 08 Oct 2015 Link to this post


    We are currently implement an "Office Inspired" application, so are making use of the backstage view. One of the items contains a list of files the user can open. When this list becomes larger than the window, rather than a scrollbar appearing on the list, it appears on the entire backstage view.

    I've attached screens of how Office currently does it, vs how it's currently working for us.

    Any suggestions on how to resolve this would be much appreciated.

    For reference, the list box is hosted in a grid, hosted in a content control.

    I did come across this thread ( ), in which it was stated that it is designed to behave like the Office backstage view. I was wondering if that is still correct ? We are currently using 2015.2.728.45, with the Office 2013 style applied.

  2. Answer
    Kiril Vandov
    Kiril Vandov avatar
    323 posts

    Posted 09 Oct 2015 Link to this post

    Hello Michael,

    We have implemented a much easier way to customize the build in ScrollViewer of the RadRibbonBackstage. By default it's ScrollBars are set to Auto and will appear when needed. However you could dissable them by setting the attached properties of the ScrollViewer ScrollViewer.HorizontalScrollBarVisibility="Disabled" and ScrollViewer.VerticalScrollBarVisibility="Disabled" after that the scrolling will be entire in your hands and the controls placed inside the RadRibbonBackstageItem.

    I hope this information helps. Please let us know if you need further assistance.

    Kind regards,
    Kiril Vandov
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. DevCraft banner
  4. Michael
    Michael avatar
    19 posts
    Member since:
    Aug 2014

    Posted 11 Oct 2015 Link to this post

    Works great !
Back to Top