Links in preview mode do not work in IE11

4 posts, 0 answers
  1. Cheryl
    Cheryl avatar
    15 posts
    Member since:
    May 2013

    Posted 30 Sep 2014 Link to this post

    When compatibility mode for IE11 is turned off, I cannot click on links when in Preview mode.

    I have been forced to set it to run under IE10. 

    <meta http-equiv="X-UA-Compatible" content="IE=10,chrome=1" />

    Is this going to be fixed?
  2. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 03 Oct 2014 Link to this post

    Hello Cheryl,

    The links in the editor's content either in Preview or Design mode are designed not to act as links, i.e., they should not be able to be click-able. This is so, because the editor should serve only as an XHTML editing tool and navigating the editable iframe to another page would cause the user to loose the content typed. 

    The links should act properly after content is submitted and/or saved to a normal HTML environment.

    Regards,
    Ianko
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Cheryl
    Cheryl avatar
    15 posts
    Member since:
    May 2013

    Posted 12 Oct 2014 in reply to Ianko Link to this post

    Thank you for your reply.

    While I understand your reasoning, there are valid scenarios where a user would want to potentially use this:  After posting/saving the content (ie the record is no longer in add/edit mode) we are showing the text content in a separate editor which only has preview mode - to show a transactional account of the record being viewed.
     
    It is for this reason we want to be able to open any attached files and potentially click links.

    We will continue to use the workaround for the moment.
  5. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 14 Oct 2014 Link to this post

    Hi Cheryl,

    Just to clear the situation:

    • There are two editors, one in Edit mode and the other in Preview;
    • The one with the Preview mode should always allow users to click on the links.

    Could you please verify if the above steps are correct? If they are not, please provide information which is the editor, where the links should act properly.

    Maybe a simple demonstrative project would be very useful to understand what exactly should be achieved.

    Regards,

    Ianko
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
Back to Top