launch browser timeout exception on recording

3 posts, 0 answers
  1. Yana
    Yana avatar
    2 posts
    Member since:
    Feb 2011

    Posted 12 Feb 2011 Link to this post

    Hi, 
    I am not able to record - went over all recommendations in forums and it does not help.
    So, I am using windows 7 (UAC is disabled),  Visulal Studio 2008 SP1 (was ran as administrator), IE8 with recommended by Telerik settings and WEBUI test studio version 2010.3.1213.0.
    I am attaching Diagnose Recorder Log. Thank you, Yana:
    [Trace:[22:01] - Using: ArtOfTest.Common, Version=2010.3.1213.0, Culture=neutral, PublicKeyToken=14a0200bfcbb7b62]
    [Trace:[22:01] - OS: Microsoft Windows NT 6.1.7600.0]
    [Trace:[22:01] - Loading Translator Groups]
    [Trace:[22:01] - ------- Function Start 'Loader.LoadTranslatorGroups' -------]
    [Trace:[22:01] - Translators Directory is : C:\Program Files\Telerik\WebUI Test Studio 2010.3\Bin\Translators]
    [Trace:[22:01] - ------- Function End 'Loader.LoadTranslatorGroups' -------]
    [Trace:[22:01] - Loading Custom Silverlight Types]
    [Trace:[22:01] - Registering Silverlight Mime Filter...]
    [Trace:[22:01] - Succesfully requested mime filter registration]
    [Trace:[22:01] - HostId: 0]
    [Trace:[22:01] - Getting Host Endpoint Address]
    [Trace:[22:01] - Creating RecorderHostClient]
    [Trace:[22:01] - Opening Connection]
    [Trace:[22:01] - Enabling Host-Side Logging]
    [Trace:[22:01] - Disabling Warning Bar]
    [Trace:[22:01] - Locating WebBrowserClass]
    [Trace:[22:01] - Attaching to WebBrowserClass Events]
    [Trace:[22:01] - Creating Embedded Window]
    [Trace:[22:01] - ------- Function Start 'RemoteRecorder.ie_DocumentComplete' -------]
    [Trace:[22:01] - Adding HWND 525674]
    [Trace:[22:01] - Get UserSettings from host]
    [Trace:[22:01] - Create RSM]
    [Trace:[22:01] - ------- Function Start 'Loader.LoadTranslatorGroups' -------]
    [Trace:[22:01] - Translators Directory is : C:\Program Files\Telerik\WebUI Test Studio 2010.3\Bin\Translators]
    [Trace:[22:01] - ------- Function End 'Loader.LoadTranslatorGroups' -------]
    [Trace:[22:01] - Call RSM.Bind]
    [Trace:[22:02] - ------- Function Start 'IERecordingSurface.InitializeDocument' -------]
    [Trace:[22:02] - DesignerBrowser is Ready. Attaching Events]
    [Trace:[22:02] - Calling AttachRecordingListener]
    [Trace:[22:02] - ------- Function Start 'IERecordingSurface.AttachRecordingListener' -------]
    [Trace:[22:02] - Inside the (lock)]
    [Trace:[22:02] - Releasing HtmlDoc References (Count:0)]
    [Trace:[22:02] - Creating the (MAIN) document reference.]
    [Trace:[22:02] - Building (FRAMES) and references.]
    [Trace:[22:02] - _nativeRecorderWindow is null]
    [Trace:[22:02] - Attaching the keyboard events]
    [Trace:[22:02] - Starting the KeyBoard Recorder]
    [Trace:[22:02] - Keyboard Recorder Started]
    [Trace:[22:02] - ------- Function End 'IERecordingSurface.AttachRecordingListener' -------]
    [Trace:[22:02] - Calling RefreshDomTree]
    [Trace:[22:02] - Setting IsDomLoaded=true]
    [Trace:[22:02] - Calling InitializeSilverlightRecorder()]
    [Trace:[22:02] - ------- Function Start 'IERecordingSurface.InitializeSilverlightRecorder' -------]
    [Trace:[22:02] - ------- Function Start 'SilverlightRecorderManager.InitializeRecorders' -------]
    [Trace:oldRect: {X=232,Y=195,Width=391,Height=313}, newRect: {X=217,Y=175,Width=480,Height=648}]
    [Trace:oldRect: {X=217,Y=175,Width=480,Height=648}, newRect: {X=217,Y=175,Width=480,Height=648}]
    [Trace:oldRect: {X=220,Y=205,Width=452,Height=534}, newRect: {X=220,Y=205,Width=452,Height=534}]
    [Trace:oldRect: {X=220,Y=205,Width=452,Height=534}, newRect: {X=220,Y=205,Width=452,Height=534}]
    [Trace:oldRect: {X=220,Y=205,Width=486,Height=583}, newRect: {X=220,Y=205,Width=486,Height=583}]
    [Trace:oldRect: {X=-3,Y=-30,Width=256,Height=133}, newRect: {X=-3,Y=-30,Width=256,Height=133}]

  2. Stoich
    Admin
    Stoich avatar
    1 posts

    Posted 14 Feb 2011 Link to this post

    Hi Yana,
        Thank you for choosing to evaluate WebUI Test Studio!

    Have you tried all of the solutions proposed in this article:
    http://www.telerik.com/automated-testing-tools/support/kb/troubleshooting/unable-to-launch-recorder.aspx

    Please note that IE might reset it's configuration back to default after updating so recheck IE to make sure you're using the recommended settings.

    Have you previously installed older versions of WebUI or Design Canvas?

    Also, could you please also give me the actual exception message. A video demonstrating the problem would also be helpful (Jing is great for this).

    Hope to hear from you soon!
     
    Best wishes,
    Stoich
    the Telerik team
    Interested in Agile Testing? Check out Telerik TV for a recording of Automated Testing in the Agile Environment
  3. Yana
    Yana avatar
    2 posts
    Member since:
    Feb 2011

    Posted 14 Feb 2011 Link to this post

    Thank you, I found the problematic add-in: "Credential Manager for HP ProtectTools". Now I am able to record
Back to Top