Kendo UI Scaffolder Hijacks "Add Controller"

9 posts, 0 answers
  1. Nick
    Nick avatar
    86 posts
    Member since:
    Mar 2008

    Posted 02 Sep Link to this post

    Reading the docs on the scaffolder (http://docs.telerik.com/kendo-ui/aspnet-mvc/scaffolding) shows the dialog appearing when Add | New Scaffolded Item is selected, which is fine.

    Unfortunately when I pick Add | Controller I still get the Kendo UI Scaffolder dialog when all I want is a plain MVC controller.

    How can I fix this behaviour?

  2. Rumen
    Admin
    Rumen avatar
    12846 posts

    Posted 06 Sep Link to this post

    Hi Nick,

    You are the first to report this issue and I was unable to reproduce it with Visual Studio 2015.

    Can you please see my test in the following video and let me know what I am missing?

    You can try to uninstall and reinstall the Telerik ASP.NET MVC VSExtensions.

    Thank you!

    Best regards,
    Rumen
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. UI for ASP.NET MVC is VS 2017 Ready
  4. Rod
    Rod avatar
    10 posts
    Member since:
    May 2010

    Posted 20 Oct in reply to Rumen Link to this post

    I will try to uninstall as suggested above but I wanted to let you know that I have had the same thing happen.
  5. Rumen
    Admin
    Rumen avatar
    12846 posts

    Posted 21 Oct Link to this post

    Hi Rod,

    Thank you for raising a flag.

    On my end everything is fine as you can see in this screenshot. My VS2015 is running version 2016.9.926 of Telerik ASP.NET MVC VSExtensions. Can you please update your version to it and test again?


    Best regards,
    Rumen
    Telerik by Progress
    Check out the new UI for ASP.NET Core, the most complete UI suite for ASP.NET Core development on the market, with 60+ tried-and-tested widgets, based on Kendo UI.
  6. Rod
    Rod avatar
    10 posts
    Member since:
    May 2010

    Posted 24 Oct in reply to Rumen Link to this post

    Rumen,

    I was just playing around in ASP.NET Core to see what it was like. Spent way too much time just getting it up and running plus this issue. I ended up repairing VS2015 to get everything back to normal and then dropped it for now. I will revisit it in the future when I have more time.

    BTW, I always keep Telerik up to date and I did confirm we were running the same version. Maybe it is an interaction with another extension. If I find out, I will post an update.

    Thanks for the response!

    ROD>

  7. Developer Developer
    Developer Developer avatar
    2 posts
    Member since:
    Nov 2005

    Posted 31 Oct Link to this post

    I am also having this issue.  Have done the install and reinstall.  Please see the attached screen shot of what I get when I choose Add>New Scaffold Item.
  8. Rumen
    Admin
    Rumen avatar
    12846 posts

    Posted 02 Nov Link to this post

    Hi guys,

    Thank you for your patience!

    I was able to reproduce the problem as shown here http://screencast.com/t/iB1e9gPA1iX and logged it for fixing in our bug tracker here.

    Please, excuse us for the temporary inconvenience!


    Best regards,
    Rumen
    Telerik by Progress
    Check out the new UI for ASP.NET Core, the most complete UI suite for ASP.NET Core development on the market, with 60+ tried-and-tested widgets, based on Kendo UI.
  9. Matt
    Matt avatar
    6 posts
    Member since:
    May 2011

    Posted 3 days and 15 hours ago in reply to Rumen Link to this post

    Also experiencing the same problem, if I manage to resolve I will post an update.
  10. Matt
    Matt avatar
    6 posts
    Member since:
    May 2011

    Posted 3 days and 14 hours ago in reply to Matt Link to this post

    I also had the latest Telerik VS extensions which I removed via program and features, I then restarted my laptop and tried to add a controller again.  This time ReSharper templates appeared!  I suspended ReSharper and then finally I got the VS templates back again....

    Matt.

Back to Top
UI for ASP.NET MVC is VS 2017 Ready