Kendo UI Menu custom theme IE 8 glitch

3 posts, 0 answers
  1. Matt
    Matt avatar
    2 posts
    Member since:
    Jun 2012

    Posted 19 Apr 2013 Link to this post

    I've modified the Bootstrap theme, essentially just changing some background-colors, gradients, colors, border colors etc. But for some reason, when I use my custom theme on the Kendo UI Web Menu demo, there is a glitch when mousing over items in IE 8. (The original Kendo UI theme and Bootstrap theme work as expected.)

    I've been searching through my custom CSS and can't find the issue. I've done a file diff on the CSS themes, inspected elements in Chrome Developer tools, IE 8 Developer tools, and cannot still cannot find the problem.

    I have posted a question in StackOverflow:
    http://stackoverflow.com/questions/16113226/kendo-ui-menu-custom-theme-ie-8-glitch
    StackOverflow question

    The StackOverflow question goes into similar detail, with links to these jsBins to test out in IE 8:
    jsBin (custom theme - IE 8 glitch)
    jsBin (original Bootstrap)

    If anyone could help me with this custom theme CSS glitch in IE 8 that would be most helpful.

    Thanks!
  2. Kamen Bundev
    Admin
    Kamen Bundev avatar
    1532 posts

    Posted 23 Apr 2013 Link to this post

    Hi Matt,

    Seems you found the answer in StackOverflow.

    I'm just posting here to let people know and head there to read it.

    All the best,
    Kamen Bundev
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  3. Kendo UI is VS 2017 Ready
  4. Matt
    Matt avatar
    2 posts
    Member since:
    Jun 2012

    Posted 23 Apr 2013 Link to this post

    Yes, the problem was due to a minor syntax problem with the IE CSS filter attribute for gradients (and/or IE opacity).

    StackOverflow answer

Back to Top