Kendo Grid Not Showing Row Values

11 posts, 2 answers
  1. Craig
    Craig avatar
    35 posts
    Member since:
    Feb 2012

    Posted 04 Feb 2013 Link to this post

    Hi there,
    Today I was working through adding a Kendo Grid to my project when I noticed that the Kendo Grid is not showing the row values. First I thought I was something messed up on my side but then I noticed the same behavior on the Kendo Dojo site.
    I am using Firefox 18.0.1. However I have tested this in IE 10 and Chrome and I am not seeing the same problem.
  2. OnaBai
    OnaBai avatar
    55 posts
    Member since:
    Aug 2012

    Posted 04 Feb 2013 Link to this post

    I've just updated Firefox to 18.0.1 (on OSX) and it works fine!
    Did you check with Firebug if there is some error message?
  3. Kendo UI is VS 2017 Ready
  4. Craig
    Craig avatar
    35 posts
    Member since:
    Feb 2012

    Posted 05 Feb 2013 Link to this post

    I looked at Firebug. There is the error during step 2.

    TypeError: $(...).find(...)[0].codeEditor is undefined
    $(e.contentElement).find("div")[0].codeEditor.refresh();
    http://try.kendoui.com/javascripts/index.js
    Line 215

    Also I am using Windows 8.
  5. Alexander Valchev
    Admin
    Alexander Valchev avatar
    2875 posts

    Posted 06 Feb 2013 Link to this post

    Hi guys,

    I did not manage to reproduce the problem you described. For your convenience I am attaching a screen shot.
    Could you please check it and let me know what I am missing?

    Kind regards,
    Alexander Valchev
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  6. Craig
    Craig avatar
    35 posts
    Member since:
    Feb 2012

    Posted 06 Feb 2013 Link to this post

    It appears you are testing on Windows 7. I am experiencing this error on Windows 8.
    I am attaching a screenshot for your review.
  7. Answer
    Alexander Valchev
    Admin
    Alexander Valchev avatar
    2875 posts

    Posted 08 Feb 2013 Link to this post

    Hello Craig,

    Thank you for the clarification. I was able to reproduce the issue you described on Windows 8 with Firefox, however we will need more time to consider this case. I will forward the problem to the corresponding team members for further investigation.

    Did you tried the same configuration outside of Dojo simulator? Please check this example - it is working as expected on my side. I believe that problem is not directly connected with the Grid control.

    Regards,
    Alexander Valchev
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  8. Craig
    Craig avatar
    35 posts
    Member since:
    Feb 2012

    Posted 08 Feb 2013 Link to this post

    Alexander,

    I was able to confirm your test worked as expected. Thank you for escalating. Can you please let me know when a fix is available?
  9. Brandon
    Admin
    Brandon avatar
    21 posts

    Posted 12 Feb 2013 Link to this post

    Hi Craig,

    I just tried to duplicate this issue on Windows 8 with Firefox 18 and was not able to do so with either Dojo lesson that uses the Grid (Web / Widget Theming & Framework / DataSource). Can you confirm that you're running the latest version of Firefox (18.0.2) and that this issue happens when you follow the steps exactly as described in the script?
     

    Thanks,
    Brandon
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  10. Craig
    Craig avatar
    35 posts
    Member since:
    Feb 2012

    Posted 12 Feb 2013 Link to this post

    I did try this again and notices it fails. I have attached a screenshot for your review.
  11. Brandon
    Admin
    Brandon avatar
    21 posts

    Posted 15 Feb 2013 Link to this post

    Hi Craig,

    Thanks for the follow-up. Alexander has been able to replicate the issue with FF 18.0.2 on Win8, but I've been unable to after repeated attempts, so it appears that the problem is inconsistent even in FF on Win8. 

    That said, I'll add this item to the backlog for the Kendo Dojo and we'll take a look in the future. In the meantime, since this is not an issue with Kendo UI itself, you should be fine using the Grid, and the Dojo in any other browser on Win8.
     
    Thanks,
    Brandon
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  12. Answer
    Craig
    Craig avatar
    35 posts
    Member since:
    Feb 2012

    Posted 20 Mar 2013 Link to this post

    This looks like it was fixed in Q1 - 2013! Thanks for all your hard work Telerik!
Back to Top
Kendo UI is VS 2017 Ready