JustCode Vanishes from Visual Studio 2010 In Terminal Server Environment

7 posts, 1 answers
  1. Mark Gallucci
    Mark Gallucci avatar
    11 posts
    Member since:
    May 2010

    Posted 12 May 2011 Link to this post

    Our development team has run into an issue with JustCode for Visual Studio 2010.  We have the product installed on one of our terminal servers and for a time it worked fine, appearing in VS for each team member's session.  At some point within the past two weeks, JustCode ceased showing up (no menu options, no code block lines) for every team member.  In fact, it only seems to show up for the first person who opens Visual Studio.  For everyone else, it's as if it never existed.  We have already tried reinstalling the product, but this did not alleviate the issue.

    Any suggestions?
  2. Ivo Bratoev
    Admin
    Ivo Bratoev avatar
    107 posts

    Posted 25 May 2011 Link to this post

    Hi Mark Gallucci,

    Let me first make sure I understand right your environment. What terminal server do you use? Window Server 2008? R2? Do each user connect simultaneously to the server? Do you use Remote Desktop? Do all of you work on the same solution?
    It would helps us a lot if you can send us the JustCode logs. You can find them in "%LocalAppData%\JustCode\Logs". You can create a support ticket and send them there.

    All the best,
    Ivo Bratoev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft banner
  4. Mark Gallucci
    Mark Gallucci avatar
    11 posts
    Member since:
    May 2010

    Posted 25 May 2011 Link to this post

    We operate under Windows Server 2008 R2 and are using Visual Studio 2010 (version 10.0.30319.1) with Team Foundation Server. We're not all working on the same solution. We've confirmed that this issue does not occur for users with local admin rights. I've created a support ticket and have included the most recent JustCode log. The log appears to support our findings. Any way to circumvent the local admin rights requirement?
  5. Ivo Bratoev
    Admin
    Ivo Bratoev avatar
    107 posts

    Posted 06 Jun 2011 Link to this post

    Hello Mark Gallucci,

    I received the logs you sent me and I am currently investigating the issue.
    Truth be told, we haven't test JustCode in such environment and officially we don't support it. But we do support running JustCode under user without admin rights so I will investigate the issue further.

    Best wishes,
    Ivo Bratoev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Mark Gallucci
    Mark Gallucci avatar
    11 posts
    Member since:
    May 2010

    Posted 06 Jun 2011 Link to this post

    Just to clarify, a user without admin rights *can* access JustCode, just not more than one simultaneously.  On the other hand, multiple users who have admin rights are able to access JustCode simultaneously.
  7. Answer
    Svetlozar
    Admin
    Svetlozar avatar
    269 posts

    Posted 14 Jun 2011 Link to this post

    Hi Mark Gallucci,

    We found the problem and we are currently working on the fix. We just released an internal build, so that fix will be included in the next one, so please, stay tuned. 

    Kind regards,
    Svetlozar Angelov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Mark Gallucci
    Mark Gallucci avatar
    11 posts
    Member since:
    May 2010

    Posted 08 Jul 2011 Link to this post

    The latest internal build appears to have fixed this issue.  Thank you.
Back to Top
DevCraft banner