Justcode stopped working

5 posts, 0 answers
  1. GlenB
    GlenB avatar
    37 posts
    Member since:
    Apr 2010

    Posted 03 Jul 2013 Link to this post

    Hi, the forum thread I was working has disappeared after Zdravko altered the type of topic, so I cannot reply to it. Instead of re-explaining the issues I will paste in the old topic details below.

    Can someone please respond to this with a way I can send the log files through - thanks.

    PREVIOUS POST IS BELOW:
    From: Telerik Admin
    Date: 7/3/2013 6:47:09 AM
    Hi Glen,

     I just changed the type of the topic so you should be able to send archived files here.
    If you still find it difficult I would create a ftp account for you.
    Thanks.

    Regards,
    Zdravko
    Telerik
    Share what you think about JustCode with us, so we can help you even better! You can use the built-in feedback tool inside JustCode, our forum, or our JustCode feedback portal.




    From: GlenB
    Date: 7/3/2013 12:51:11 AM
    Thanks for your reply.

    I have created the logs you requested, however I can't attach them as this forum only allows graphics files to be attached. I can't submit a support ticket as the system says I need an active subscription (mine expired recently). Is there an email address (or another way) I can send the logs to you?

    Thanks.




    From: Telerik Admin
    Date: 7/2/2013 8:38:10 AM
    Hi Glen,

     Thanks for your feedback.
    We will need some more information in order to investigate your issue.

    Would you send us your logs located at %localappdata%\JustCode\Logs?

    Install the latest available to you version, turn on Verbose logging from JustCode Options > General > Logging and send us the logs (if any) in addition to previous ones.

    Configure WER so a dump file will be generated next time VS hangs and send it to us. I will attach a registry file that could do that for you. All you have to do is to create CrashDumps folder in your C: directory where the .dmp file will be produced.

    Start VS with /log and send us the following file:
    %APPDATA%\Microsoft\VisualStudio\<version>\ActivityLog.xml where <version> is 10.0 in your case.

    If you still experience the exception you can disable JustCode from VS Tools menu > Add-In manager instead of uninstalling it.
    Thanks.

    I look forward to hearing from you.

    Regards,
    Zdravko
    Telerik
    Share what you think about JustCode with us, so we can help you even better! You can use the built-in feedback tool inside JustCode, our forum, or our JustCode feedback portal.




    From: GlenB
    Date: 7/1/2013 7:51:32 PM
    This has just started occurring on JustCode Q1 2013 SP1 (2013.1.404.2).

    It used to work fine and now I'm getting the Exception on engine operation StartProcess errors which stops Justcode from working and causes VS2010 to hang when closing and to also build up memory usage. I'm assuming something has changed on the remote (telerik) end of the web service as this has only just started happening.

    I have uninstalled and reinstalled it but the same problem is occurring? At the moment I have no choice but to remove Justcode until the problem is solved.

    Screenshots are attached and a portion of the log file is below:
    ERROR 2013-07-02 10:42:08.326 : Exception on engine operation StartProcess [HResult: 80131604]
    System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at net.pipe://localhost/JustCode/d5ee1d6f-fd68-475a-b732-7e3df4bff07f that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.


    Is anyone else experiencing this? Any solutions Telerik?




    From: FunkyHippy
    Date: 7/20/2012 3:10:12 AM
    Hi

    I've finally managed to get the time to check this.
    I've just installed 2012.2.719.1 and all is working fine.

    So whatever the issues was has been fixed.

    Thank You. :)




    From: Telerik Admin
    Date: 7/6/2012 10:05:51 AM
    Hello,

    We released an internal build yesterday. Could you give it a spin and let us know whether your issue is fixed?
    Thank you for your help!

    All the best,
    Ivan
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >><_o3a_p>





    From: Telerik Admin
    Date: 7/3/2012 9:21:14 AM
    Hello,

    Thank you for your feedback. Actually this is expected. Comparing the current version and the last found version helps us know whether an update dialog should be shown.
    They are the same only if you have the latest version. However, it cannot cause the exception you had.
    I am glad that you were able to workaround it. As I said, we will introduce a fix for it in the next internal build.
    If you have any more questions or remarks, please do not hesitate to contact us again!

    Greetings,
    Ivan
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >><_o3a_p>





    From: Filip Jacobs
    Date: 7/3/2012 9:11:31 AM
    I noticed in 
    C:\Documents and Settings\<user>\Application Data\JustCode\applicationStateSettings-justcode.xml
    different versions for
    <CurrentProductVersion>2012.2.608.4</CurrentProductVersion>
    and
    <LastFoundVersion>2012.2.622.1</LastFoundVersion>

    The difference still exists but JustCode works just fine.
    Because the LastFoundVersion had been installed I thought this might be an issue.
    I suppose the "LastFoundVersion" is the last version in Telerik's repository and not the one found on our development machine ?






    From: Telerik Admin
    Date: 7/3/2012 8:59:38 AM
    Hello,

    Thank you for your feedback. We made improvements and this issue should be fixed.
    The fix will be included in our next internal build.
    Could I ask you to give it a spin and let us know whether your issues are resolved?
    @Filip Jacobs:
    Could I ask you to give us some more information about the discrepancy you noticed? Discrepancy between what? And what is that xml file that you are talking about?
    Thank you for your help!

    Greetings,
    Zdravko
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >><_o3a_p>





    From: Filip Jacobs
    Date: 6/29/2012 3:28:07 PM
    I noticed a discrepancy between JustCode versions in a JustCode directory in ...\Program Files\<user>\...
    Two different versions were mentioned in the same xml file !!!

    Subsequently I solved the issue by

    - uninstalling all telerik software
    - reboot the system
    - remove manually all remaining telerik directories (in program files, program data, etc.)
    - reinstalling the previously not working versions with the msi-files.

    From now on I will

    (1) first uninstall the software to update before installing new versions
    (2) use msi-files instead of the control panel to install it




    From: FunkyHippy
    Date: 6/29/2012 8:28:15 AM
    I'm not sure tbh I think the issue is with the latest version of JustCode but the process that worked for me was:

    • uninstalled JustCode latest version (version 2012.2 608)
    • removed All extensions from Visual Studio
    • reinstalled JustCode latest version (version 2012.2 608

    still not working so

    • unsinstalled JustCdode latest version (version 2012.2 608) 
    • reboot pc
    • installed JustCode  previous release (version 2012.1 3211)
    • Installed NuGet VS Extension

    Which all worked for me.






    From: Filip Jacobs
    Date: 6/29/2012 8:09:59 AM
    Did it solve the problem ?
    I first thought is was a conflict with the "Power Tools" extension but after uninstalling it the problem remained.




    From: FunkyHippy
    Date: 6/29/2012 6:30:42 AM
    The other thing I did do (when I tried to get the latest version working) was to disable/remove all Visual Studio extensions.
    The only extension I have now is the Nuget package manager.





    From: Filip Jacobs
    Date: 6/29/2012 6:04:01 AM
    I tried to install the latest update with and without internal builds and the
    current manual installation JustCode_2012.2.608_Dev.msi.
    It all resulted in the same problem you stated earlier.




    From: FunkyHippy
    Date: 6/29/2012 5:31:10 AM
    As an update I've now got just code working by going back to the previous version (2012.1 321). As soon as I install the latest version its stop working with the error I described earlier.




    From: Filip Jacobs
    Date: 6/29/2012 4:36:41 AM
    I'm having exactly the same problem and it seems to slow down everything dramatically.
    Could anyone please offer a solution ?




    From: FunkyHippy
    Date: 6/28/2012 8:40:09 AM
    Just code has recently stopped working for me in VS2010. I've been using it fine for the past few months but today it won't work at all.
    The extension is loading but none of the Intelli-sense is working and any Keyboard shortcuts that JustCode overrides are also not working (i.e F12 doesn't work but if I use the context menu it's fine).

    I've tried uninstalling and reinstalling JustCode via the telerik Control Panel and still no joy.

    I've attached the log created when I create a new Console Project in VS (as it gives the same error whenever I create or open a project).

     Here is the exception that gets logged:

    INFO 2012-06-28 14:30:12.987 : OK
    ERROR 2012-06-28 14:30:13.065 : Exception on engine operation StartProcess [HResult: 80131604] 
    System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.TimeoutException: This request operation sent to net.pipe://localhost/JustCode/30863283-67b3-4370-9540-f2bd0cd9e656 did not receive a reply within the configured timeout (00:01:00).  The time allotted to this operation may have been a portion of a longer timeout.  This may be because the service is still processing the operation or because the service was unable to send a reply message.  Please consider increasing the operation timeout (by casting the channel/proxy to IContextChannel and setting the OperationTimeout property) and ensure that the service is able to connect to the client.


    Server stack trace: 
       at System.ServiceModel.Dispatcher.DuplexChannelBinder.SyncDuplexRequest.WaitForReply(TimeSpan timeout)
       at System.ServiceModel.Dispatcher.DuplexChannelBinder.Request(Message message, TimeSpan timeout)
       at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
       at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
       at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)


    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at Telerik.JustCode.CodeAnalysisService.Common.IEngineService.RegisterCallback()
       at Telerik.JustCode.CodeAnalysisService.Client.RemoteEngine.#4Dh(List`1 extensionDirectories) in c:\B10\Manticore\Production_Release\Sources\source\CodeAnalysisService.Client\RemoteEngine.cs:line 201
       at Telerik.JustCode.CodeAnalysisService.Client.RemoteEngine.#h.#Jb.#gB() in c:\B10\Manticore\Production_Release\Sources\source\CodeAnalysisService.Client\RemoteEngine.cs:line 16777215
       --- End of inner exception stack trace ---
       at System.RuntimeMethodHandle._InvokeMethodFast(IRuntimeMethodInfo method, Object target, Object[] arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeType typeOwner)
       at System.RuntimeMethodHandle.InvokeMethodFast(IRuntimeMethodInfo method, Object target, Object[] arguments, Signature sig, MethodAttributes methodAttributes, RuntimeType typeOwner)
       at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks)
       at System.Delegate.DynamicInvokeImpl(Object[] args)
       at Telerik.JustCode.CodeAnalysisService.Client.RemoteEngine.#h.#2Dh.#jEh() in c:\B10\Manticore\Production_Release\Sources\source\CodeAnalysisService.Client\RemoteEngine.cs:line 931
    Log Site Stacktrace:
       at Telerik.JustCode.Common.Logging.ExceptionInfo.GetExceptionString(Exception ex) in c:\B10\Manticore\Production_Release\Sources\source\Logging\ExceptionInfo.cs:line 91
       at Telerik.JustCode.Common.Logging.LogService.LogException(Exception ex, String message) in c:\B10\Manticore\Production_Release\Sources\source\Logging\LogService.cs:line 129
       at Telerik.JustCode.Common.Logger.LogException(Exception ex, String message) in c:\B10\Manticore\Production_Release\Sources\source\Logging\Logger.cs:line 117
       at Telerik.JustCode.CodeAnalysisService.Client.RemoteEngine.#h.#2Dh.#jEh() in c:\B10\Manticore\Production_Release\Sources\source\CodeAnalysisService.Client\RemoteEngine.cs:line 16777215
       at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
       at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
       at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
       at System.Threading.ThreadHelper.ThreadStart()


    INFO 2012-06-28 14:31:13.052 : Service timeout on engine operation SetMetadataCachePath
  2. Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 04 Jul 2013 Link to this post

    Hello Glen,

     I am sorry for the confusion. Here is a link from where you can send a zip file with max size 20mb.
    I also made a ftp account if the form above doesn't fit your needs: 
    Set FTP in Active Mode!
    IP address: 82.103.64.22
    Username: GlenBeumer
    Password: Ub[e$#F13z]

    Beware that the account will expire in 15 days.

    Recently we were aware of similar issue when Garmin Express is installed on users' machine. We found out that it prevents JustCode process to load. Would you check if you have this product installed?

    Thanks.

    Regards,
    Zdravko
    Telerik
    Share what you think about JustCode with us, so we can help you even better! You can use the built-in feedback tool inside JustCode, our forum, or our JustCode feedback portal.
  3. DevCraft banner
  4. GlenB
    GlenB avatar
    37 posts
    Member since:
    Apr 2010

    Posted 04 Jul 2013 Link to this post

    I'm glad you mentioned Garmin Express - I only installed it a few days ago so that must be the culprit!

    Is there a way to get justcode to work without removing Garmin Express? If not, I will remove Garmin Express.

    I'll still send my log files through the link you sent me in case they're helpful.

    Thanks.
  5. Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 05 Jul 2013 Link to this post

    Hello Glen,

     Here is an article that explains what is the reason of this misbehavior. I think it is mentioned that if you deactivate the autostart of GARMIN update service everything should be fine.
    Thanks.

    Regards,
    Zdravko
    Telerik
    Share what you think about JustCode with us, so we can help you even better! You can use the built-in feedback tool inside JustCode, our forum, or our JustCode feedback portal.
  6. GlenB
    GlenB avatar
    37 posts
    Member since:
    Apr 2010

    Posted 05 Jul 2013 Link to this post

    Thanks Zdravko. I have emailed Garmin Support (not sure if it'll do any good), but it's good to know I can rectify the issue locally.

    Very impressed with the support even though my subscription is not current - keep up the good work!
Back to Top
DevCraft banner