Just Code no longer working

11 posts, 0 answers
  1. Blake
    Blake avatar
    8 posts
    Member since:
    Mar 2011

    Posted 08 Mar 2012 Link to this post

    After the last update to Just Code, Just Code no longer appears on my menu bar all the code highlighting is gone. The product has totally stopped working. Addin manager shows it's there but it does not function.
  2. Ivo Bratoev
    Admin
    Ivo Bratoev avatar
    107 posts

    Posted 08 Mar 2012 Link to this post

    Hello,

     Can you try to restart your machine, uninstall JustCode and install it again?

    Greetings,
    Ivo Bratoev
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
  3. DevCraft banner
  4. Blake
    Blake avatar
    8 posts
    Member since:
    Mar 2011

    Posted 08 Mar 2012 Link to this post

    That did not work.
  5. Ivo Bratoev
    Admin
    Ivo Bratoev avatar
    107 posts

    Posted 12 Mar 2012 Link to this post

    Hi,

     To further investigate the issue I will need some more information from you. Can you send us your JustCode logs? They are in %LocalAppData%\JustCode\Logs. Please zip the whole Logs folder and send it to us. 
    Can you also send us logs from starting up your Visual Studio? To do that close all Visual Studio instances, and run Visual Studio with the "/log" switch. The log will be here: %APPDATA%\Roaming\Microsoft\VisualStudio\<version>\ActivityLog.xml. Please send this one to us as well.

    Greetings,
    Ivo Bratoev
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
  6. Eric Schoenholzer
    Eric Schoenholzer avatar
    138 posts
    Member since:
    Mar 2004

    Posted 02 Apr 2012 Link to this post

    Any news here?
    Same for me. JustCode is gone.

    Thanks
  7. Ivo Bratoev
    Admin
    Ivo Bratoev avatar
    107 posts

    Posted 06 Apr 2012 Link to this post

    Hello Eric,

     Can you send me the logs I requested in my previous post?

    Regards,
    Ivo Bratoev
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  8. Eric Schoenholzer
    Eric Schoenholzer avatar
    138 posts
    Member since:
    Mar 2004

    Posted 06 Apr 2012 Link to this post

    Thanks, I opened already ticket, problem solved.
    Was a corrupt settings file.
  9. Markus
    Markus avatar
    205 posts
    Member since:
    Nov 2005

    Posted 11 Apr 2012 Link to this post

    Dear Eric

    Can you post the solution. Same stuff here. Dont see just code in the title bar. Deinstalled and installed 2011.3.1221 fresh but nothing.

    Markus

  10. Ivan
    Admin
    Ivan avatar
    106 posts

    Posted 11 Apr 2012 Link to this post

    Hi,

    Could you provide us with more information, so that we are able to investigate your issue. I will repost how you could help us:
    Can you send us your JustCode logs? They are in %LocalAppData%\JustCode\Logs. Please zip the whole Logs folder and send it to us. 
    Can you also send us logs from starting up your Visual Studio? To do that close all Visual Studio instances, and run Visual Studio with the "/log" switch. The log will be here: %APPDATA%\Roaming\Microsoft\VisualStudio\<version>\ActivityLog.xml. Please send this one to us as well.

    As for the issue that Eric Schoenholzer had: the settings file of JustCode was corrupted. What you could do is to go to %appdata%/justcode. There you can rename(delete will also work, but I suggest rename in this situation) "userConfiguration.xml" and "settings-justcode.xml".
    This will force JustCode to create new settings files.
    If this fixes the issue, could you send us the settings files so that we can investigate them.
    Your help is highly appreciated!

    Regards,
    Ivan
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  11. Markus
    Markus avatar
    205 posts
    Member since:
    Nov 2005

    Posted 11 Apr 2012 Link to this post

    Dear Ivan

    QUOTE
    What you could do is to go to %appdata%/justcode. There you can rename(delete will also work, but I suggest rename in this situation) "userConfiguration.xml" and "settings-justcode.xml".
    This will force JustCode to create new settings files.
    UNQUOTE

    This did the trick.

    However, only the userConfiguratin.xml was recreated. The settings-justcode.xml was not recreated.
    The filesizes of userConfiguratin_old.xml and userConfiguratin.xml seem to be identical but I can not open the _old in VS and it opens in simple editor blank :-)

    Kind Regards Markus
  12. Ivan
    Admin
    Ivan avatar
    106 posts

    Posted 11 Apr 2012 Link to this post

    Hello,

    I am glad to hear that your issue has been resolved. We are doing some improvements on our settings infrastructure and such issues should no longer be present.
    As for the "settings-justcode.xml": it will be created when you open the options dialog of JustCode and press "Save".
    If you have any more questions or remarks, please do not hesitate to contact us again!

    Regards,
    Ivan
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

Back to Top
DevCraft banner