jquery plugin problem

4 posts, 0 answers
  1. Lukas Faber
    Lukas Faber avatar
    2 posts
    Member since:
    Oct 2009

    Posted 05 Nov 2010 Link to this post

    Hello.

    I'm trying to use "inplace editor" jquery plugin (http://jquery-in-place-editor.googlecode.com/svn/trunk/demo/index.html) on page which use telerik rad ajax controls. I have added necessary scripts fallow the instruction (http://www.telerik.com/help/aspnet-ajax/using-jquery-plugins.html) but it doesn't work. When I move my code to plain html page (not aspx) with jquery (without telerik) everything works fine (like on demo page). To be sure I have tested the example from telerik help with BlockUI and this works fine to, so probably the inplace editor" plugin use some more advanced functionalities of jQuery.
    Anyone was successfully to integrate this plugin into aspx with telerik scripts registered?

    I will be grateful for any help,
    Lukas
  2. Peter
    Admin
    Peter avatar
    6637 posts

    Posted 11 Nov 2010 Link to this post

    Hello Lukas,

    I tested the plugin in a simple Telerik web site and it worked. Attached is a demo for reference.

    Greetings,
    Peter
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Lukas Faber
    Lukas Faber avatar
    2 posts
    Member since:
    Oct 2009

    Posted 12 Nov 2010 Link to this post

    Hello Peter.

    Thank you for your respond but it still doesn't work.
    When I'm testing your (and my version too) in Mozilla Firefox or Google Chrome the text disappears instead of be replaced by input (text or select). Please let me know what is your experience in different browsers the IE.

    Greetings,
    Lukas

    ps.
    I'm not sure it's important but ... I'm using Windows XP Prof (32 bit)/Windows 7 Prof (64 bit), with browsers IE 7/8 (via IE compatibility mode), Chrome 7.0 and FireFox 3.6 on both computers.

  5. Peter
    Admin
    Peter avatar
    6637 posts

    Posted 19 Nov 2010 Link to this post

    Hello Lukas,

    Indeed, there is a problem in Firefox, but it seems to be related to the jQuery plugin itself. I tested it without Telerik controls and got the same problem. Attached is a test sample for reference.


    Regards,
    Peter
    the Telerik team
    Browse the vast support resources we have to jumpstart your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.
Back to Top