January Month View Issue

2 posts, 0 answers
  1. Blake
    Blake avatar
    14 posts
    Member since:
    Jun 2010

    Posted 17 Oct 2011 Link to this post

    Hello,

    I'm having an issue with the January months from 2011 and earlier in the Month view of the RadScheduleView.  The issue (as shown in the attachment for January 2011) is that any days before the first Sunday of the month do not display.  As you can see in January 2011, January 1st gets cut off even though the VisibleDateRange in code shows 12/26 - 2/6.  In January 2010, January 1st and 2nd get cut off and in January 2009, January 1st-3rd get cut off and so on.  January 2012 works fine as January 1st is the first Sunday of the month.

    I'm not sure if this is a bug or if I am doing something to break the native functionality.  Has this been seen before?

    Thanks,
    Blake
  2. Boyan
    Admin
    Boyan avatar
    758 posts

    Posted 20 Oct 2011 Link to this post

    Hi Blake,

    We are not aware of this issue and was not able to reproduce this behavior at our side. It appears that the whole first week is missing. Could you provide some more info on your project, what properties do you have set on the RadScheduleView and MonthViewDefinition? Are you using the FirstDayOfWeek, VisibleDays properties? It will be best if you could send us a sample code in a new support thread, this will greatly help us to reproduce and fix the problem.


    Regards,
    Boyan
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. DevCraft banner
Back to Top